Edit Mode. Need to increase responsiveness when dragging icons around page and moving them through pages or to dock

RESOLVED FIXED

Status

RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: pabloUX, Assigned: crdlc)

Tracking

({perf})

unspecified
All
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-basecamp:-)

Details

(Whiteboard: interaction, UX-P1)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
* Environment: Unagi, Nov 16 dev. build. 
* Repro: navigate to Home. Tap-hold icon to enter edit mode. Drag any icon around page, to dock, or through pages.
* Expected: Entering edit mode, there should be a fluid response to user dragging icons around page, when included in dock or when moving to new pages. Icon behavior should follow users finger and grid should rearrange accordingly (including creating new pages)
* Actual: Dragging icons in edit mode are cumbersome (takes finesse and several tries to move them). If gesture is quick, UI moves to change page, not to move icon.
(Reporter)

Updated

6 years ago
Priority: -- → P2
Whiteboard: UX_QA
(Reporter)

Updated

6 years ago
Whiteboard: UX_QA → UX_QA, Interaction design
Completely agree. Current Edit mode is very unresponsive, bordering on hostile to user. Should fix for release.
Keywords: perf, polish
Priority: P2 → P1
Whiteboard: UX_QA, Interaction design → UX_QA, interaction
blocking-basecamp: --- → ?
Keywords: polish
Summary: [Home-Dock-Grid/IxD] Edit Mode. Need to increase responsiveness when dragging icons around page and moving them through pages or to dock → Edit Mode. Need to increase responsiveness when dragging icons around page and moving them through pages or to dock
blocking-basecamp: ? → -
Priority: P1 → --
Whiteboard: UX_QA, interaction → interaction, UX-P1
Cristian, is this just a matter of tweaking a few timing variables?

Gordon, can you look at fixing in the UX branch?
Flags: needinfo?(crdlc)
Whiteboard: interaction, UX-P1 → interaction, UX-P1, uxbranch
Removing the "uxbranch" label after talking to Gordon. Need info from Cristian on level of effort required to fix.
Whiteboard: interaction, UX-P1, uxbranch → interaction, UX-P1
(Assignee)

Comment 4

6 years ago
During the day I can do research on it
Flags: needinfo?(crdlc)
(Assignee)

Comment 5

6 years ago
I have good news, I am reaching better responsiveness, in a couple of hours I will land a pr to fix it IMHO
(Assignee)

Updated

6 years ago
Assignee: nobody → crdlc
(Assignee)

Comment 6

6 years ago
Created attachment 690349 [details]
Proposed patch v1
Attachment #690349 - Flags: review?(21)
Comment on attachment 690349 [details]
Proposed patch v1

I have a small question about the value choosen for the constants otherwise it looks good.

Please re-request review once it has been answered.
Attachment #690349 - Flags: review?(21)
(Assignee)

Updated

6 years ago
Attachment #690349 - Flags: review?(21)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Comment 9

5 years ago
This should be reopened. The issue is present in v1.4 on ZTE Open: I have a very hard time moving app icons from page to page. Even when I manage to push the icon more then half way (which is hard due to the size of the finger v. screen) it still doesn't go to the next page. Most of the time when I manage to drag an icon to the page on right the scrolling is so fast that the icon ends up on a new page!
You need to log in before you can comment on or make changes to this bug.