Edit mode: when scrolling to landing page, animation to come back to grid should be slower

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Homescreen
RESOLVED WONTFIX
6 years ago
5 years ago

People

(Reporter: pabloUX, Unassigned)

Tracking

({perf})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [c= p= s=2013.10.25 u=] UX_QA, interaction)

(Reporter)

Description

6 years ago
* Environment: Unagi, Nov 16 dev. build. 
* Repro: unlock phone. Go to app grid. Enter edit mode. (1) slide pages to landing page or (2) drag icon to landing page (but not to dock)
* Expected: user drags icon or swipes to landing page. If user releases while in landing page:
- (if dragging icon) landing page moves out of focus while either letting the icon go back to grid (to page where icon is coming from)
 - (if gesturing from grid page) Landing page moves out of focus back to first page of grid (to the right) 
* Actual: User goes to landing page while in edit mode, landing page moves out of focus too quickly, which feels like an error.
(Reporter)

Updated

6 years ago
Whiteboard: UX_QA
(Reporter)

Updated

6 years ago
Priority: -- → P4
(Reporter)

Updated

6 years ago
Whiteboard: UX_QA → UX_QA, Interaction design
In Nov 21 build the user is prevented from dragging icons to Landing screen (which is good). Swiping to Landing screen is also deterred, with quick swipes having no effect. However the user can still drag it into view if they pull slowly. When they let go, the page snaps back to the first grid screen. This inconsistency feels like a glitch. I recommend we remove the ability to slowly drag the Landing screen into view.

Overall we need a more elegant and obvious design solution. The above is a bare-minimum solution.
Priority: P4 → P3
Summary: : [Home-Dock-Grid/IxD]: Edit mode. When scrolling to landing page, animation to come back to grid should be slower → Edit mode: when scrolling to landing page, animation to come back to grid should be slower
Whiteboard: UX_QA, Interaction design → UX_QA, interaction

Updated

5 years ago
Keywords: perf

Updated

5 years ago
Priority: P3 → --
Whiteboard: UX_QA, interaction → [c= p= s= u=] UX_QA, interaction

Comment 2

5 years ago
Closing this since so much has changed in homescreen in the last year.  UX team, please re-open if this is still an issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(firefoxos-ux-bugzilla)
Resolution: --- → WONTFIX

Updated

5 years ago
Whiteboard: [c= p= s= u=] UX_QA, interaction → [c= p= s=2013.10.25 u=] UX_QA, interaction

Updated

5 years ago
Flags: needinfo?(firefoxos-ux-bugzilla)
You need to log in before you can comment on or make changes to this bug.