Dock should not be present at everything.me panel. Animate it to go away

VERIFIED FIXED

Status

P3
normal
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: pabloUX, Assigned: ranbena)

Tracking

unspecified
All
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-basecamp:+)

Details

(Whiteboard: interaction, UX-P1)

Attachments

(1 attachment)

Comment hidden (empty)
(Reporter)

Updated

6 years ago
Priority: -- → P1
Whiteboard: UX_QA
(Reporter)

Updated

6 years ago
Whiteboard: UX_QA → Interation design
Component: Gaia::Homescreen → Gaia::Everything.me
Need to fix this for release.
blocking-basecamp: --- → ?
Whiteboard: Interation design → interaction
Summary: [everything.me/Home] Dock should not be present at everything me panel. Animate it to go away → Dock should not be present at everything.me panel. Animate it to go away
Severity: normal → critical
Keywords: smoketest
Hey Josh, Ami will contact you about this.
Should we implement it or not? thanks
Flags: needinfo?(jcarpenter)
I spoke with Ami today and we're going to revisit this and a few other items next week, so hold off for now, and I will follow up.
Flags: needinfo?(jcarpenter)
Flags: needinfo?(jcarpenter)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Josh, any update on this one?
Not have to be a smoketestblocker
Keywords: smoketest

Comment 7

6 years ago
Josh, what's the latest thinking here?
Let's hide the dock. The thinking from the TEF + Moz UX teams is unanimous on this one.

* In v1 we want to increase the contrast between the "two worlds" of E.me versus the installed-apps grid
* We also want to maximize the available vertical real estate for the categories
Flags: needinfo?(jcarpenter)
No problem. We'll have a pull request ready soon.
Severity: critical → normal
Priority: P1 → --
Whiteboard: interaction → interaction, UX-P1
Agree, hiding makes sense here.  Thanks.
It works well now. Every changes to the homescreen is a risk so I won't block on this.
blocking-basecamp: ? → -
Renoming. Ran said "no problem", and UX team feels strongly that this needs to be reverted back to the original implementation for usability reasons. This is one we're going to fight for.
blocking-basecamp: - → ?
Assignee: nobody → ran
Depends on: 813026
blocking-basecamp: ? → +
Priority: -- → P3
Created attachment 690863 [details]
Patch - redirect to github PR

Make sure the OS dock is kept hidden across all Ev.me
Attachment #690863 - Flags: review?(crdlc)
the code is ok, although I have a thought. In previous version in the first view with the dock, the categories had a specific viewport, now it should be bigger because the dock is hidden. We have more space for categories with this change but I don't see any change in CSS
Attachment #690863 - Flags: review?(crdlc) → review+
https://github.com/mozilla-b2g/gaia/commit/8731bc824ebcb7ec5503725aaaa3d3e3745fe9a9
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(In reply to crdlc from comment #14)
> the code is ok, although I have a thought. In previous version in the first
> view with the dock, the categories had a specific viewport, now it should be
> bigger because the dock is hidden. We have more space for categories with
> this change...

Agreed. The dock hiding should open up the screen for more E.me results.
The extra space is already implemented.

Brain.FFOS.showMenu() that was removed in this commit triggered a className change that minimised the shortcuts container area. https://github.com/mozilla-b2g/gaia/blob/master/apps/homescreen/everything.me/modules/Shortcuts/Shortcuts.css#L42

Comment 18

6 years ago
This issue fixed for  device Ungia; build #20130103070201 v.1
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.