[everything.me] eliminate task switching functionality to e.me search results or category results. Confuses user with application switching

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Everything.me
RESOLVED WONTFIX
5 years ago
4 years ago

People

(Reporter: pabloUX, Assigned: Yosef Waysman)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: interaction, UX-P5)

Comment hidden (empty)
(Reporter)

Updated

5 years ago
Priority: -- → P2
Whiteboard: UX_QA
(Reporter)

Updated

5 years ago
Component: Gaia → Gaia::Everything.me
Summary: . eliminate task switching functionality to e.me search results or category results. Confuses user with application switching → [everything.me] eliminate task switching functionality to e.me search results or category results. Confuses user with application switching
Whiteboard: UX_QA → UX_QA, Interaction design
Pablo can you provide some more specifics here? I don't undersand the description.
Priority: P2 → --
Whiteboard: UX_QA, Interaction design → interaction
(Reporter)

Updated

5 years ago
Whiteboard: interaction → interaction, UX-P2
(Reporter)

Comment 2

5 years ago
Repro:
1.Open an app in everything.me (it opens in a wrapper)
2.Tap the home button in order to come back home

Expected:
- Leave the wrapper and come back home

Actual:
- It comes to everything.me main screen

Actually, current behavior have sense for the user, because there is no other way to exit and it seems that real users feel comfortable with it, but it implies a second behavior of the main button and it should be discussed.
(Reporter)

Updated

5 years ago
Flags: needinfo?(aymanmaat)
(In reply to Pablo Sanchez [:pabloUX] from comment #2)
> Actually, current behavior have sense for the user, because there is no
> other way to exit and it seems that real users feel comfortable with it, but
> it implies a second behavior of the main button and it should be discussed.

We've been back and forth on this already. Current behavior is correct and consistent, IMO. 

Pressing Home always takes the user back to the last-opened-page of the Home screen. The user can open an app to try it out, and then jump back to the grid page they were just on. Everything.me is simply exhibiting this same behaviour, since it's another page on the home screen, albeit a "special" different one. 

We can always revisit in v2.
Whiteboard: interaction, UX-P2 → interaction, UX-P5

Updated

5 years ago
Flags: needinfo?(aymanmaat)

Comment 4

4 years ago
Can we close this?
Flags: needinfo?(jcarpenter)

Updated

4 years ago
Assignee: nobody → yosef
(Assignee)

Comment 5

4 years ago
I agree with Josh.

Can we close this?
Flags: needinfo?(psanchezm)

Comment 6

4 years ago
Closing per comment 3. Please re-open if needed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX

Updated

4 years ago
Flags: needinfo?(psanchezm)
Flags: needinfo?(jcarpenter)
You need to log in before you can comment on or make changes to this bug.