Reword for dlg-when you want to quit app while sending mail

VERIFIED FIXED in mozilla0.9.4

Status

SeaMonkey
MailNews: Message Display
VERIFIED FIXED
17 years ago
7 years ago

People

(Reporter: Sheela Ravindran, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
mozilla0.9.4

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(7 attachments)

(Reporter)

Description

17 years ago
Buildid:  2001051508 win98, mac, linux

Fix for bug 52328 was to prompt the user with a dialog when they want to quit 
the application while sending is in progress. This could be the reason for a 
slow connection or a large file which could be taking too long to send. 

The dlg information is as follows:

-The dlg title bar says"Close Mail window"
-The dlg has an OK and Cancel button
-The wording is " There is mail being sent, do you want to quit now or cancel 
and quit after the mail is sent?

When I read the dlg the first time it was not clear to understand what OK and 
cancel would result in.  I feel the wording can be changed to something more 
simple and clear.  I spoke to ninoschka and she agreed that the dlg should be 
reworded. 
 
steps to be able to see the dialog:
-open browser and mail
-compose a new message 
-attach a large file so that you have enough time to quit the application
-click on send button
-when sending is in progress go to file menu item and do file|quit
-Should be able to see the above dialog.
(Reporter)

Comment 1

17 years ago
change qa contact and cc related people

ccing Jennifer and Robin since the dlg needs rewording.  
QA Contact: esther → sheelar
good catch.  I think if you send a big message, but use the window manager to
close the window before it is done, you'll get the same message.

it must have been added to handle the case where someone did "File | Quit" while
compose windows were open.  but that dialog shows up in "non-quit" cases.

over to varada, cc ducarroz.
Assignee: sspitzer → varada

Comment 3

17 years ago
Robin, please comment, thanks.

Title: Sending Message in Progress

1. "Mail is currently in the process of sending a message. Would you like to 
quit once the message has been sent?"   
Buttons - "OK" (quits once mail sent)  "Cancel" (doesn't quit after mail sent)

Most users will probably want the message sent before they quit, this covers 
that behavior. If user Cancels or OK's the dialog above, they can still click 
"Cancel" on the Progress dialog, not yet implemented, to stop a message in 
progress.


2. "Mail is currently in the process of sending a message. Would you like to 
quit now or wait until the message has been sent before quitting?"
Buttons - "Quit Now"  "Quit After Msg Sent"

Comment 4

17 years ago
Once the application starts to quit it is only a question of whether we allow
the mailcompose window to stay open till it sends the mail or close along with
the rest of the app without sending the mail. the choices therefore should be
whether you want to quit right away or quit after sending the message
(equivalent to OK and Cancel -OK:quits and Cancel:quits after sending)
Sorry about that, I capitalized "in".  Patch for spec #2 coming up, then I'll
re-patch #1.

Comment 9

17 years ago
I like Jennifer's #2 suggestion, except that I'd swap the wording: "Mail is
currently in the process of sending a message. Would you like to 
wait until the message has been sent before quitting or quit now?"
And I'd make the "Quit After Msg Sent" button the default action.
Geez, it would help if I patched the right portion of the file.  I totally 
messed up.  New, correct patch coming up (I was patching the *subject* portion.  
I'm so silly.)
Index: composeMsgs.properties
===================================================================
RCS file: /cvsroot/mozilla/mailnews/compose/resources/locale/en-US/composeMsgs.p
roperties,v
retrieving revision 1.39
diff -u -r1.39 composeMsgs.properties
--- composeMsgs.properties      2001/05/01 22:19:48     1.39
+++ composeMsgs.properties      2001/05/17 22:06:18
@@ -206,5 +206,7 @@
 CheckMsg=Do not show me this dialog box again.

 ## Strings used by prompt when Quitting while in progress
-quitComposeWindowTitle=Close Mail Window
-quitComposeWindowMessage=There is mail being sent, do you want to quit now or c
ancel and quit after the mail is sent?
+quitComposeWindowTitle=Sending Mail in Progress
+quitComposeWindowMessage=Mail is
+currently in the process of sending a message. Would you like to
+wait until the message has been sent before quitting or quit now?

Comment 12

17 years ago
bad: "Sending Message in Progress"
slightly better: "Sending Message"

bad: "Ok" "Cancel"
not good: "Quit Now" "Quit After Msg Sent"
better: "Quit" "Wait"
Hardware: PC → All

Comment 13

17 years ago
I like the suggestions from robin and timeless. To summarize:

Dialog Title: Sending Message

Text: "Mail is currently in the process of sending a message. Would you like to 
wait until the message has been sent before quitting or quit now?"

Buttons - "Quit"  "Wait" (default)

Everyone ok with this?
That's much improved.  It took me only one read of the wording to understand,
unlike some of the previous ones ;-)

Comment 15

17 years ago
Looks good, thanks.
Created attachment 35175 [details] [diff] [review]
Patch, changes wording, buttons will need to be changed, as well.

Comment 17

17 years ago
One little suggestion...
Current:    "... before quitting or quit now?"
Suggestion: "... before quitting or quit immediately?"

That would give the user even clearer idea on the difference between the two 
choices.

And correspondingly on the Buttons...
Current:    "Quit"  "Wait"
Suggestion: "Quit Immediately"  "Wait"

How's that?
"Quit immediately" would be a massive button.  "Quit Now" is acceptable, isn't it?

Comment 19

17 years ago
Yup yup... "Quit Now" is OK for me.
Created attachment 35189 [details] [diff] [review]
Patch (this one actually works, no newlines ;-)
Please note: that patch doesn't change the buttons, anybody know where these bad
boys live?
(Reporter)

Comment 22

17 years ago
I liked the one from jglick's comments on 2001-05-18 13:12:)
*** Bug 84137 has been marked as a duplicate of this bug. ***

Comment 24

17 years ago
Well I know I'm too late but I would propose the Netscape 4.7 message, which is 
short, sweet, and helpful. Plus it won't be confusing to people who see 
the "quit" message simply when trying to close a new message window.

Message has not been sent. Do you want to save the message in the Drafts folder?
*** Bug 85808 has been marked as a duplicate of this bug. ***

Comment 26

17 years ago
Oh dear. Has anyone ever seen something like the currently proposed alert in a 
professional quality app?

+----------------------------------------------------+
|Not Quite Useful Title :::::::::::::::::::::::::::::|
+----------------------------------------------------+
|   .   Microsoft Word is currently in the process   |
|  /!\  of saving your document. Would you like to   |
|  """  wait until the document has been saved       |
|       before quitting or quit now?                 |
|                                                    |
|                          (   Eh?   ) (( Pardon? )) |
+----------------------------------------------------+

No? Of course not. (Cue for Timeless to give some obscure example from 
relational databases or something, but never mind.) If the user chooses to 
close a document (or the entire app) while the document is being saved, the app 
waits until the save has finished and *then* closes it. To do anything else -- 
to even give the express *option* of doing anything else -- would be dangerous 
and unnecessary.

Sending for e-mail is highly analagous, UI-wise, to saving a document in a 
productivity app. I don't know what proportion of e-mail messages are ever 
saved as draft just before they're sent, but I suspect it's very low. So for 
the application to quit in the middle of sending a message (or for that to be 
an option in an alert) would be a rather non-intuitive form of extreme 
dataloss.

If a message is being sent, and the user asks for the window to be closed (by 
whatever method), Mozilla should just wait until (a) the message finishes 
sending (which is likely to only take a few seconds anyway), or (b) the user 
clicks the `Stop' button in the composition window to stop the send. On (b),
*then* Mozilla can put up the usual `This message has not been sent. Do you 
want to save the message in the Drafts folder?' alert which susie mentioned.

Comment 27

17 years ago
I think there is a difference between saving a document and having a send 
operation in progress.
 

Comment 28

17 years ago
Created attachment 40371 [details]
examples from Word and Eudora

Comment 29

17 years ago
I was going to dig for the windows logoff/shutdown dialog that has 'wait' 'end 
task' 'cancel' but i couldn't get a terminal session to start. (and i didn't 
really want to log off my console...).

Didn't mpt say the ? mark icon was no longer used in windows? or was it the i 
icon, i can't remember :(

Comment 30

17 years ago
removed myself from cc

Comment 31

17 years ago
Jglick, Word is not a good example of a good UI. Even if they use a similar
wording, it's confusing.

Comment 32

17 years ago
um. word's ui was so good, they fired the office assistant for OfficeXP. 
actually i'm told he gets temping or part time work in XP if you are careless.

Did i mention that you and mpt are trying to kill all uses of Yes and No while 
claiming microsoft doesn't use them anymore?

Comment 33

17 years ago
No you didn't, which is just as well since it's not true.

Having said that, I'm surprised at the existence of the alerts jglick posted. 
They both look pretty appalling.

Comment 34

17 years ago
*** Bug 91480 has been marked as a duplicate of this bug. ***
*** Bug 94321 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 36

17 years ago
nominating this bug for nsbranch since there has been so many dups for this bug.
More so that this dlg really needs rewording.
Keywords: nsBranch
implementing jglick's proposal (2001-05-18 13:12) now.
Assignee: varada → sspitzer
here comes the patch...
Severity: minor → normal
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9.4

Comment 40

17 years ago
r=varada
fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Reporter)

Comment 42

17 years ago
Seth,
Thanks so much for fixing it:)     
(Reporter)

Comment 43

17 years ago
verified the dlg wording has been changed according to jennifer comments as of 
2001-05-18 13:12.  But the only change from jennifer's comments is the buttons 
"quit and wait" has been interchanged to "wait and quit".  I will log a separate 
bug for it. 
2001-08-13-06 win98
2001-08-13-04 mac
2001-08-13-06 linux
Status: RESOLVED → VERIFIED
*** Bug 99366 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.