Events with duplicate attendee lines cause Lightning and Thunderbird to freeze

RESOLVED DUPLICATE of bug 875739

Status

Calendar
Lightning Only
--
critical
RESOLVED DUPLICATE of bug 875739
5 years ago
3 years ago

People

(Reporter: Jacob Fortune, Unassigned)

Tracking

({hang})

Lightning 1.8

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

5 years ago
Created attachment 683204 [details]
Contains an example ics file that, if imported to a subscribed calendar, will cause Lightning to hang.

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.11 (KHTML, like Gecko) Chrome/23.0.1271.64 Safari/537.11

Steps to reproduce:

From a migration, we have some questionable ics data in our system.  One particularly problematic situation we've seen is when a VEVENT has two entries for the same ATTENDEE.  In our case, these ATTENDEE properties have identical PARTSTAT and CU-TYPEs, but some varied X-properties.  See attached file for an example.


Actual results:

When Lightning runs into these events, Thunderbird stops responding completely.  Nothing is logged in error console before freezing completely, so it's not clear what is happening.


Expected results:

Lightning should handle the processing of bad data more gracefully.  If you subscribe to a calendar with a bad event in it, the only way I've found to recover Thunderbird at all is to remove the subscription from the prefs.js file.
(Reporter)

Updated

5 years ago
Component: General → Lightning Only

Updated

4 years ago
Severity: normal → critical
Keywords: hang
Created attachment 8483573 [details] [diff] [review]
Fail when a process does not produce a leak log.

Here's the trivial test harness part of this.
Comment on attachment 8483573 [details] [diff] [review]
Fail when a process does not produce a leak log.

Oops, wrong bug number.
Attachment #8483573 - Attachment is obsolete: true
I think this might be the same root cause as bug 875739
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 875739
You need to log in before you can comment on or make changes to this bug.