Closed Bug 813277 Opened 8 years ago Closed 8 years ago

Unable to long-tap hold on the home-screen to invoke the wallpaper menu

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-basecamp:+, firefox18 fixed, firefox19 fixed, firefox20 fixed)

VERIFIED FIXED
B2G C2 (20nov-10dec)
blocking-basecamp +
Tracking Status
firefox18 --- fixed
firefox19 --- fixed
firefox20 --- fixed

People

(Reporter: aaronmt, Assigned: ttaubert)

References

Details

(Keywords: regression, unagi)

Attachments

(1 file, 1 obsolete file)

Long-tap on the home-screen. There used to be a menu where one could invoke the wallpaper switcher (or I believe access the camera). Long-tapping now does nothing.

--
Unagi 11/19
Attached patch patch v1 (obsolete) — Splinter Review
Not sure if that's the right way to fix this but FireContextClick() should only be called by a timer initiated by user action. The patch works well for me.
Assignee: nobody → ttaubert
Attachment #683292 - Flags: feedback?(mounir)
Comment on attachment 683292 [details] [diff] [review]
patch v1

Review of attachment 683292 [details] [diff] [review]:
-----------------------------------------------------------------

I'm not the best person to review or give a formal feedback on this.

My gut feeling is that this is odd but I don't know this code enough.
Attachment #683292 - Flags: feedback?(mounir) → feedback?(bugs)
Comment on attachment 683292 [details] [diff] [review]
patch v1

Ah, makes sense, but use nsAutoHandlingUserInputStatePusher as a stack variable.
Attachment #683292 - Flags: feedback?(bugs) → feedback+
Component: Gaia → Gaia::Homescreen
Attached patch patch v2Splinter Review
Attachment #683292 - Attachment is obsolete: true
Attachment #683963 - Flags: review?(bugs)
Status: NEW → ASSIGNED
Comment on attachment 683963 [details] [diff] [review]
patch v2


> 
>+      nsIDocument *doc = mGestureDownContent->GetCurrentDoc();
nsIDocument* doc


How could we test this? Do we have gaia tests?
Attachment #683963 - Flags: review?(bugs) → review+
(In reply to Olli Pettay [:smaug] from comment #5)
> How could we test this? Do we have gaia tests?

No idea... I don't know our gaia test suites well and whether we're able to simulate a long-tap to test this. Maybe Vivien knows?
Duplicate of this bug: 813413
blocking-basecamp: ? → +
Priority: -- → P1
Can we land this and file a follow-up for a test? If not, is anyone familiar with emulating long-taps and/or testing that behavior?
Keywords: smoketest
Target Milestone: --- → B2G C2 (20nov-10dec)
Tim,

Long ago I wrote a synthetic_gestures.js module for testing my gesture_detector.js module.  It includes JS code that might work to simulate long presses.  But I can't find synthetic_gestures.js in the codebase anymore.  I think the automation people might be using it though.  mdas or lightsofapollo might know where it has gone.
Nevermind... My synthetic_gestures.js library would almost certainly be too high-level for testing what you want to test.
Ok, I think I'm going to land this and file a follow-up if no one objects.
https://hg.mozilla.org/mozilla-central/rev/1817f6bc2681
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Comment on attachment 683963 [details] [diff] [review]
patch v2

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 801995
User impact if declined: wallpaper selection broken and contextmenu in general
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky): Low risk, small and safe patch
String or UUID changes made by this patch: None
Attachment #683963 - Flags: approval-mozilla-beta?
Attachment #683963 - Flags: approval-mozilla-aurora?
Comment on attachment 683963 [details] [diff] [review]
patch v2

Low risk to desktop/mobile, and b-b+. Approving for branches.
Attachment #683963 - Flags: approval-mozilla-beta?
Attachment #683963 - Flags: approval-mozilla-beta+
Attachment #683963 - Flags: approval-mozilla-aurora?
Attachment #683963 - Flags: approval-mozilla-aurora+
Unagi Build ID:20130103070201 - no repro - longpress homescreen invokes menu with options - wallpaper,gallery, and camera, fix verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.