A lot of B2G specific code sneaking into marionette client

RESOLVED DUPLICATE of bug 997244

Status

RESOLVED DUPLICATE of bug 997244
6 years ago
5 years ago

People

(Reporter: ahal, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [runner])

(Reporter)

Description

6 years ago
See http://mxr.mozilla.org/mozilla-central/search?string=b2g&find=%2Ftesting%2Fmarionette%2F.*\.py&findi=&filter=^[^\0]*%24&hitlimit=&tree=mozilla-central

Yes, much of this stuff is ok. But there are other things (like install_gecko) that seem a little too b2g specific for marionette.

Figuring out how to structure everything is probably not the highest priority, just wanted to file so it would remain in the back of my mind.
Depends on: 816236
I think the right solution here is to make a B2G-specific subclass of Marionette (similar to what we did for GaiaUnitTests) and move the B2G-specific code there.  We could almost move most of the code from mozb2g into this new class.

I'm not sure when anyone will have the time to do this, though.  Maybe an intern this summer?
Whiteboard: [runner]
(Reporter)

Comment 2

5 years ago
Most of the b2g specific stuff this bug was referencing was in emulator.py. I've filed bug 997244 to remove emulator.py from marionette and into mozrunner. As a part of that, I'm devising a way to keep b2g specific stuff out of emulator.py which essentially fixes this bug. Therefore resolving duplicate.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 997244
You need to log in before you can comment on or make changes to this bug.