Firefox ignores "Exclude simple hostnames" on OS X, when firefox's proxy settings are set to honour system settings

RESOLVED DUPLICATE of bug 580530

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 580530
5 years ago
5 years ago

People

(Reporter: chee rabbits, Unassigned)

Tracking

16 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:16.0) Gecko/20100101 Firefox/16.0
Build ID: 20121024073032

Steps to reproduce:

Tested in 15, 16 and 19-Nightly.

Start ssh tunnel `ssh -D2000 user@server.lol`
Set apple macintosh's Network>Advanced>Proxies to SOCKS Proxy localhost:2000
Check "Exclude simple hostnames" in OS X network settings.
Set Firefox's advanced network settings to "Use system proxy settings".


Actual results:

Firefox correctly uses the proxy, but when attempting to connect to a http://localhost/ address it connects to server.lol instead of local machine. (same goes for 127.1/).

This can be worked around by adding "localhost" and "127.0.0.1" to OS X Network Settings or by manually configuring the proxy settings in Firefox. This is irritating if you're adding a lot of virtualhosts with different names :(


Expected results:

Firefox should be a good fox and not use the proxy for hostnames that seem local.

<3
(Reporter)

Comment 1

5 years ago
just realised this is a dupe.
it shouldn't be a wontfix though. 

>function FindProxyForURL(url, host)
>{
>   if(isPlainHostName(host)
>     || dnsDomainIs(host, ".internal"))
>   {
>      return "DIRECT";
>   }
>   else
>   {
>      return "PROXY 192.168.168.0.128:80";
>   }
>}


Something similar to this pac file should just come into action when exclude simple hostnames is checked.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 580530
You need to log in before you can comment on or make changes to this bug.