If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

YouTube's HTML5 is so broken

RESOLVED WORKSFORME

Status

()

Core
Audio/Video
RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: armenzg, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
* join the beta: http://www.youtube.com/html5

The only way for the video to work is by scrolling up and down or moving the mouse.
The audio is completely fine. 
This has been broken for a while already but I wasn't sure if we were just waiting on a fix from Flash (I always forget that I'm on the trial).

Build identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:19.0) Gecko/19.0 Firefox/19.0

I doubt the Flash info is needed but just in case:
Shockwave Flash
    File: Flash Player.plugin
    Version: 11.5.502.110
    Shockwave Flash 11.5 r502

Comment 1

5 years ago
Can you provide more detailed steps to reproduce?

http://www.youtube.com/watch?v=gCfemmxqaRg works fine for me in Firefox trunk.  I don't have Flash enabled.
Component: General → Video/Audio
Product: Firefox → Core
Version: unspecified → Trunk
(Reporter)

Comment 2

5 years ago
Jesse, can you try going to another tab and back?
Or even your own url, if it opens in a new tab and you switch to it you should hit it.

I'm not anymore on the trial but I can reproduce it by going back and forth between tabs.
What does the graphics section of about:support say?  Can you reproduce this if you disable hardware accelerated graphics?
(Reporter)

Comment 4

5 years ago
Graphics
Device ID                  0x 116
GPU Accelerated Windows    0/1
Basic Vendor               ID0x8086
WebGL Renderer             Intel Inc. -- Intel HD Graphics 3000 OpenGL Engine
AzureCanvasBackend         quartz
AzureContentBackend        none
AzureFallbackCanvasBackend none

When I disabled everything started working
When I enabled back again... nothing was broken anymore :(
In other words, I can't reproduce it anymore.

The setting I changed was "Use hardware acceleration when available"

On another note, I noticed that the HTML version of the following YouTube video is not smooth. This can be easily noticed when the title shows up at the beginning of the video.
http://www.youtube.com/watch?v=xA2cMWvhrSE&feature=related

Comment 5

4 years ago
Can this bug be resolved invalid?
(Reporter)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.