Closed Bug 813446 Opened 7 years ago Closed 7 years ago

[Contact] Crash after importing around 445 contacts from Facebook

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect, P1)

x86
Gonk (Firefox OS)
defect

Tracking

(blocking-basecamp:+)

VERIFIED FIXED
blocking-basecamp +

People

(Reporter: khu, Assigned: jmcf)

Details

(Keywords: smoketest)

Attachments

(4 files)

STR: 
1. Flash unagi_2012-11-19.zip. 
2. Import contact from Facebook during 1st time experience. I have 445 contacts imported. 
3. After 1st time experience is completed, launch contact from home screen. 
4. Contact is launched and then, disappear immediately. 

Expected result: 
I can browse contacts from Contact app. 

Actually result: 
Contact app is gone. Not quite sure if it's crashed or OOM. 
At least, I can't find contact app running, after long press Home button.
blocking-basecamp: --- → ?
Also seen importing 200 contacts and also when importing around 120.
Unagi
Gaia 5dcc1b1
Gecko 3c0b3b4
Keywords: smoketest
I have been able to import successfully 283 Friends. After that it seems there is crash but we don't know if it is the homescreen or the Contacts app. After that I have been able to open the Contacts App without trouble. Anyway we will continue testing this up to 500 friends which is the maximum FB allows for test users.
Status: NEW → UNCONFIRMED
Ever confirmed: false
(In reply to Jose M. Cantera from comment #2)
> I have been able to import successfully 283 Friends. After that it seems
> there is crash but we don't know if it is the homescreen or the Contacts
> app 

or even Gecko itself. The attached capture shows the the import process is finishing successfully. 

 After that I have been able to open the Contacts App without trouble.
> Anyway we will continue testing this up to 500 friends which is the maximum
> FB allows for test users.
Attached image capture 283 friends
Component: Gaia → Gaia::Contacts
Need consistent scenario
blocking-basecamp: ? → -
Keywords: qawanted
I agree with David. We need to know how many apps are opened at the same time and the status of the device. Today I was able to import more than 500 friends without trouble. Also we need to know whether the crash while importing or after importing and what app actually crashes, the HS, Contacts or the whole Gecko.
I import 346 contacts from Facebook, and it's behavior just like what Kevin said
After open the contact, it will crash immediately and then back to homescreen
keep testing on this
As I test by importing 50 contacts each time,
it works fine in 0 -> 50, 50 -> 100, 100 -> 150 (both on import process and contact list)
In 150 -> 200, import process will cause contact app crash after it finish but then restart the contact, it works fine
In 200 -> 250, both import process will cause contact crash after it finish and contact app will crash immediately after it launchs
Attached file Profiling data
I collected the profiling data for reference. So, I will nominate this one as bb? again. IMO, this should be bb+. If you need anything else for analysis, please raise it here.
blocking-basecamp: - → ?
By the way, I don't open other apps and it can be reproduced in my Unagi always.
Assignee: nobody → jmcf
blocking-basecamp: ? → +
Keywords: qawanted
Priority: -- → P1
I suspect its caused by the contacts now will load all the pictures for each contact, it could cause OOM when there is lots of pictures
Maybe we can solve this by using dynamic way like only load the pictures in current screen
But since the Facebook import list won't cause crash, it just still remain unclear

I'm planning to test with import several contacts that all have pictures, and see if it can cause the same behavior like this case
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(In reply to John Shih from comment #11)
> I suspect its caused by the contacts now will load all the pictures for each
> contact, it could cause OOM when there is lots of pictures
> Maybe we can solve this by using dynamic way like only load the pictures in
> current screen

Yes, we actually do the same in the FB Import page, we only load those images which are on the viewport

> But since the Facebook import list won't cause crash, it just still remain
> unclear
> 
> I'm planning to test with import several contacts that all have pictures,
> and see if it can cause the same behavior like this case
Hi Jose, 
thanks for answering!
So you surely can solve this bug with the same way, right :)
hi jose, any progress on this?  have we identified the problem and working on a fix?   reiterating this is a P1 smoketest blocker that is already a week old.  Thanks.
yes, I have a patch for fixing the problem. I'm awaiting for the landing of 796531 as there are interdependent changes with this bug. Once that lands I will PR my patch.

Thanks!
Bug 796531 has been merged -- can you go ahead with the PR for this one?
NOTE: If blocking-basecamp+ is set, just land it for now.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: crashes importing hundreds of contacts with images
Testing completed: 
Risk to taking this patch (and alternatives if risky):
Attachment #686987 - Flags: review?(jmcf)
Attachment #686987 - Flags: review?(francisco.jordano)
Attachment #686987 - Flags: approval-gaia-master?(francisco.jordano)
Comment on attachment 686987 [details]
Patch v1 loading images only in viewport

This is bb+ so doesnt need master approval.

Please merge once you get the r+ :)

Thanks!
Attachment #686987 - Flags: approval-gaia-master?(francisco.jordano)
Attachment #686987 - Flags: review?(jmcf) → review+
https://github.com/mozilla-b2g/gaia/commit/9e567b0b8314bc350b9b822b50b9aa19c5280d34
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
verified on Unagi
2012-12-06
gaia master : 03599af2fe40bcf924377b6e737a7796a0052f88
mozilla-beta : 8482faeb8a8b
Status: RESOLVED → VERIFIED
Comment on attachment 686987 [details]
Patch v1 loading images only in viewport

This one has been already merged and verified by qa
Attachment #686987 - Flags: review?(francisco.jordano)
You need to log in before you can comment on or make changes to this bug.