[Contacts] After deleting one contact the list is empty although you have more contacts

VERIFIED FIXED

Status

Firefox OS
Gaia
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: crdlc, Assigned: crdlc)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

188 bytes, text/html
Jose Manuel Cantera
: review+
Details
(Assignee)

Description

5 years ago
This bug was introduced in here

https://github.com/mozilla-b2g/gaia/commit/39ba66ca65ec49cb0b5ab6dc5820fff5cada282b

Expected: no empty list with contacts after deleting one contact
(Assignee)

Updated

5 years ago
Assignee: nobody → crdlc
Status: NEW → ASSIGNED
(Assignee)

Comment 1

5 years ago
Created attachment 683473 [details]
Solved

NOTE: If blocking-basecamp+ is set, just land it for now.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: user cannot view the list after deleting contact
Testing completed: 
Risk to taking this patch (and alternatives if risky): No risk
Attachment #683473 - Flags: review?(jmcf)
Attachment #683473 - Flags: approval-gaia-master?(francisco.jordano)

Updated

5 years ago
Attachment #683473 - Flags: review?(jmcf) → review+
(Assignee)

Comment 2

5 years ago
added test, thanks Isma
Comment on attachment 683473 [details]
Solved

Love a bug that adds 95% of code for unit tests \o/
Attachment #683473 - Flags: approval-gaia-master?(francisco.jordano) → approval-gaia-master+

Comment 4

5 years ago
r+ on my side once Cristian merges the PR I have made to make more sense for the test 

https://github.com/crdlc/gaia/pull/9/files
(Assignee)

Comment 5

5 years ago
done, applied the patch, thanks
(Assignee)

Comment 6

5 years ago
https://github.com/mozilla-b2g/gaia/commit/2b5ddcffb29ad80be2bdd8580052dd7e35212b2b
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Comment 7

5 years ago
Verified on Unagi Build 20121231070201.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.