Private browsing doesn't work correctly after opening new window

VERIFIED FIXED in Firefox 19

Status

()

Firefox
Private Browsing
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: tetsuharu, Assigned: jdm)

Tracking

({regression})

Trunk
Firefox 20
x86
Mac OS X
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox17 unaffected, firefox18 unaffected, firefox19+ verified, firefox20+ verified)

Details

Attachments

(2 attachments, 1 obsolete attachment)

Enviroment:
*Firefox Nightly 20.
 http://hg.mozilla.org/mozilla-central/rev/bc69705c162d
*Intel Mac OS X 10.8

Step to reproduce:
1) open window 'A' & turn on Private-browsing.
2) close window 'A' (but keep running Firefox in dock).
3) open a new window 'B'.
4) open a URL in window 'B'.

Result:
The opened URL is recorded in browsing history.

More info:
This bug appears in Nightly 19, after http://hg.mozilla.org/mozilla-central/rev/a761bfc192b5. (Sorry, I could not report this bug immediately.)
We will need to land a patch which will fix this to aurora 19 code base.
(Assignee)

Updated

5 years ago
tracking-firefox19: --- → ?
tracking-firefox20: --- → ?
(Assignee)

Comment 1

5 years ago
Created attachment 683695 [details] [diff] [review]
Ensure windows opened in global private browsing mode with no parent present are still marked as private.

This got in-person r+ from ehsan, so I'm going to land it.
(Assignee)

Comment 2

5 years ago
To fix this on Aurora, I'll back out bug 795556.
(Assignee)

Comment 3

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/8f847258636a

Comment 4

5 years ago
Josh can you please attach the backout patch for approval?  Thanks!
status-firefox17: --- → unaffected
status-firefox18: --- → unaffected
status-firefox19: --- → affected
status-firefox20: --- → fixed

Updated

5 years ago
Assignee: nobody → josh
(Assignee)

Comment 5

5 years ago
Created attachment 683708 [details] [diff] [review]
Back out bug 795556 patch #2.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 795556
User impact if declined: Non-private windows (and associated behaviour) while in private mode in certain limited situations.
Testing completed (on m-c, etc.): Restoring previous behaviour by backing out patch that changed it.
Risk to taking this patch (and alternatives if risky): None. The code being restored ensured that all windows were correctly marked as private if PB mode was enabled.
String or UUID changes made by this patch: None.
Attachment #683708 - Flags: review?(ehsan)
Attachment #683708 - Flags: approval-mozilla-aurora?
(Assignee)

Comment 6

5 years ago
Created attachment 683713 [details] [diff] [review]
Back out bug 795556 patch #2.
(Assignee)

Updated

5 years ago
Attachment #683708 - Attachment is obsolete: true
Attachment #683708 - Flags: review?(ehsan)
Attachment #683708 - Flags: approval-mozilla-aurora?
(Assignee)

Comment 7

5 years ago
Comment on attachment 683713 [details] [diff] [review]
Back out bug 795556 patch #2.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 795556
User impact if declined: Non-private windows (and associated behaviour) while in private mode in certain limited situations.
Testing completed (on m-c, etc.): Restoring previous behaviour by backing out patch that changed it.
Risk to taking this patch (and alternatives if risky): None. The code being restored ensured that all windows were correctly marked as private if PB mode was enabled.
String or UUID changes made by this patch: None.
Attachment #683713 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/8f847258636a
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 20
Umm...  From commit log, this patch have been landed already.
But In today's nightly build (http://hg.mozilla.org/mozilla-central/rev/4f19e7fd8bea), this has not fixed yet...
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 10

5 years ago
I tried today's nightly and it works fine for me. Here are the steps I followed:

1) Enter PB session
2) Close all open windows, leaving the app open in the dock
3) Open a new window, visit an unvisited page

The new window opens to about:privatebrowsing, and the page I visit doesn't show up in the history.

Updated

5 years ago
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
Comment on attachment 683713 [details] [diff] [review]
Back out bug 795556 patch #2.

[Triage Comment]
Low risk backout, approving for Aurora 19.
Attachment #683713 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+

Comment 12

5 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/eb0aa4b2eabf
status-firefox19: affected → fixed

Updated

5 years ago
Blocks: 795556
Keywords: regression

Updated

5 years ago
tracking-firefox19: ? → +
tracking-firefox20: ? → +

Comment 13

5 years ago
Backed out: https://hg.mozilla.org/releases/mozilla-aurora/rev/fe01134efd58

Josh claims that he has a patch that actually builds:


philor
ehsan: not enough backout on aurora? needed-clobber?
dbaron
ehsan, red on aurora... oh
ehsan
philor: oh noes, that backout patch is broken
jprmc has left IRC (Input/output error)
jdm
ehsan: are you talking about the pb-related backout?
jdm
because yeah, I have a local patch which actually builds
ehsan
yeah
ehsan
good
ehsan
please land it ;)
17:09 jdm
so demanding
status-firefox19: fixed → affected
(Assignee)

Comment 14

5 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/e38abb2dab15
status-firefox19: affected → fixed
(In reply to Josh Matthews [:jdm] from comment #10)
> I tried today's nightly and it works fine for me. Here are the steps I
> followed:
> 
> 1) Enter PB session
> 2) Close all open windows, leaving the app open in the dock
> 3) Open a new window, visit an unvisited page
> 
> The new window opens to about:privatebrowsing, and the page I visit doesn't
> show up in the history.

I find the special case which has not been fixed yet.
So In step 3), if we opened a new window with 'click dock icon', the page I visit show up in the history.

If we opened a new window with 'dock-context-menu or menu-bar', this bug has been fixed in today's nightly.

So should I file a new bug?

Comment 16

5 years ago
(In reply to comment #15)
> (In reply to Josh Matthews [:jdm] from comment #10)
> > I tried today's nightly and it works fine for me. Here are the steps I
> > followed:
> > 
> > 1) Enter PB session
> > 2) Close all open windows, leaving the app open in the dock
> > 3) Open a new window, visit an unvisited page
> > 
> > The new window opens to about:privatebrowsing, and the page I visit doesn't
> > show up in the history.
> 
> I find the special case which has not been fixed yet.
> So In step 3), if we opened a new window with 'click dock icon', the page I
> visit show up in the history.
> 
> If we opened a new window with 'dock-context-menu or menu-bar', this bug has
> been fixed in today's nightly.
> 
> So should I file a new bug?

Yes, please.  Thanks a lot!
(Reporter)

Updated

5 years ago
Blocks: 814275
I confirm the fix is verified on FF 19b4 on Mac OS 10.8. I was not able to reproduce the issue mentioned by Tetsuharu in Comment 15. Is your issue from Comment 15 intermittent ?
Verified fixed on FF 20.b1:

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:20.0) Gecko/20100101 Firefox/20.0
Verified fixed on FF 20.b5
Status: RESOLVED → VERIFIED
status-firefox19: fixed → verified
status-firefox20: fixed → verified
You need to log in before you can comment on or make changes to this bug.