Enable OEM/Phone Manufacturer/Carrier to override prefs

RESOLVED WONTFIX

Status

Firefox OS
Gaia
RESOLVED WONTFIX
5 years ago
5 years ago

People

(Reporter: jaoo, Assigned: jaoo)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-basecamp:-)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Would it be possible for OEM/Phone Manufacturer/Carrier add a way of overriding gecko preferences during build time? I don't mean to add preferences in upstream, just an empty. That way carriers/oems/phone manufacturers could add their preferences in that file at build time. For example we (TEF) are about to start playing with building OTA updates and delivering them from TEF servers so we'll need to overwrite app.update.* preferences. Also, in the future, OEMs and other could do something like that.

See discussion at https://github.com/mozilla-b2g/gaia/pull/6304#discussion_r2136437
(Assignee)

Comment 1

5 years ago
This bug is not very important at all but nom'ing for basecamp.
Assignee: nobody → josea.olivera
blocking-basecamp: --- → ?
(Assignee)

Comment 2

5 years ago
Created attachment 683554 [details] [diff] [review]
WIP
Attachment #683554 - Flags: feedback?(fabrice)
Attachment #683554 - Flags: feedback?(fabrice) → feedback+
(Assignee)

Comment 3

5 years ago
Created attachment 683971 [details]
Pointer to Github PR: https://github.com/mozilla-b2g/gaia/pull/6551

NOTE: If blocking-basecamp+ is set, just land it for now.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Not Applicable.
User impact if declined: None.
Testing completed: Tested.
Risk to taking this patch (and alternatives if risky): None.
Attachment #683554 - Attachment is obsolete: true
Attachment #683971 - Flags: review?(fabrice)
Attachment #683971 - Flags: approval-gaia-master?(21)
Attachment #683971 - Flags: review?(fabrice) → review+
Why don't you use custom-prefs.js ?
(Assignee)

Comment 5

5 years ago
(In reply to Vivien Nicolas (:vingtetun) from comment #4)
> Why don't you use custom-prefs.js ?

Because of simplicity and uniformity. The OEM/PhonecManufacturer/Carrier would simply override a file at build time. Uniformity, there is already such kind of specific preference files, I mean something like {payment, ua-override}-prefs.js files so why don't use a file to allow the OEM/Phone Manufacturer/Carrier for overriding pref according its needs.
(In reply to José Antonio Olivera Ortega [:jaoo] from comment #5)
> (In reply to Vivien Nicolas (:vingtetun) from comment #4)
> > Why don't you use custom-prefs.js ?
> 
> Because of simplicity and uniformity. The OEM/PhonecManufacturer/Carrier
> would simply override a file at build time. Uniformity, there is already
> such kind of specific preference files, I mean something like {payment,
> ua-override}-prefs.js files so why don't use a file to allow the OEM/Phone
> Manufacturer/Carrier for overriding pref according its needs.

But those 2 files already have something in it. custom-prefs.js does not exists and it's whole purpose is to be customized. I just feel like we want to add a file to do something that already exists.
(Assignee)

Comment 7

5 years ago
(In reply to Vivien Nicolas (:vingtetun) from comment #6)

This sounds about right somehow. This bug/addition was discussed here [1] so I was ahead with it. That's all. I'll resolve it as wont fix.


[1] https://github.com/mozilla-b2g/gaia/pull/6304#discussion_r2139670
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
blocking-basecamp: ? → -
Attachment #683971 - Flags: approval-gaia-master?(21)
You need to log in before you can comment on or make changes to this bug.