[settings] SIM Toolkit should be disabled if no SIM is present

VERIFIED FIXED

Status

VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: pabloUX, Assigned: frsela)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:tef+, b2g18+ verified, b2g18-v1.0.0 fixed, b2g18-v1.0.1 verified)

Details

(Whiteboard: interaction, UX-P2 [triaged:1/15])

Attachments

(1 attachment)

Comment hidden (empty)
(Reporter)

Updated

6 years ago
Whiteboard: Interaction design
(Reporter)

Updated

6 years ago
Priority: -- → P2
Agreed.
Priority: P2 → --
Whiteboard: Interaction design → interaction, UX-P1
Pablo, can you confirm that this is still a problem? 

If it is, what happens when the Toolkit appears? Can the user simply cancel out of the process? Can you please decide whether to mark this UX-P2 ("should fix for release") or UX-P3 ("want to fix for release"). And if it's UX-P2, can you decide whether to nominate for basecamp-blocking?

Thanks,
Whiteboard: interaction, UX-P1 → interaction, UX-P2

Updated

6 years ago
Keywords: qawanted
2012-1-7 b2g18(v1.0) build from pvt server
unagi

STR:
  0. Turn on your phone with SIM card
  1. Make sure ur phone connected to the tele network
  2. Turn off the phone
  3. Take out the card and restart
  4. Go to "Settings" and slide all the way down

expected result: 
   No SIM card toolkit shown

actual result:
   SIM card toolkit shown

That's not good at all. You think you closed the data roaming, but it actually doesn't get closed.
Status: UNCONFIRMED → NEW
blocking-basecamp: --- → ?
Ever confirmed: true
Hardware: All → ARM
Keywords: qawanted
blocking-basecamp: ? → -
tracking-b2g18: --- → +
Keywords: regression
Assignee: nobody → frsela
Created attachment 699091 [details] [diff] [review]
Remove cached data on startup
Attachment #699091 - Flags: review?(21)
Comment on attachment 699091 [details] [diff] [review]
Remove cached data on startup

I just tried and the only side effect is that SIM Toolkit menu will not launch any command. It's not ideal but I won't hold v1 and there are many others issues to fight on before this one.

Please note that I'm not r- the code, just not giving approval to land it on master.
Attachment #699091 - Flags: review?(21) → approval-gaia-master-
(In reply to Vivien Nicolas (:vingtetun) from comment #5)
> Comment on attachment 699091 [details] [diff] [review]
> Remove cached data on startup
> 
> I just tried and the only side effect is that SIM Toolkit menu will not
> launch any command. It's not ideal but I won't hold v1 and there are many
> others issues to fight on before this one.
> 
> Please note that I'm not r- the code, just not giving approval to land it on
> master.

Yes, this only happens in two cases:

1.- You extract a SIM card which uses STK and no other SIM card is plugged, so the handset without SIM will show the STK menu with the last cached one

2.- After 1, you insert another SIM card, but this one WITHOUT STK enabled, so since this SIM card didn't sent any STK Proactive command the menu is not updated so you plugged an Carrier1 card and in settings you see the Carrier2 menu and title string.

The bad thing: a non-useful menu showed and "scared" :D user calling client relationship of Carrier1 asking what happens?

3.- If after 1 you insert a SIM card with STK enabled, the menu will be updated, anyway if the user goes to settings TOO FAST (near 0) he can see the previous menu for a little amount of seconds until it is updated.

--

So mainly, this is a UX fix
Duplicate of this bug: 829374
Blocks: 808607
blocking-b2g: --- → tef?
Please renominate if needed.
blocking-b2g: tef? → -
blocking-basecamp: - → ---
Renoming as the duplicated bug 829374 is causing certification failures
blocking-b2g: - → tef?
Besides, there is already a low risk patch
Vivien, given that it seems to be a certification failure as stated in comment 9, could you review the patch?
based on partner feedback this is becoming a tef+.  please review the patch and if technically correct let it land before 1/15.
blocking-b2g: tef? → tef+
Attachment #699091 - Flags: approval-gaia-master- → approval-gaia-master?(21)
Comment on attachment 699091 [details] [diff] [review]
Remove cached data on startup

Review of attachment 699091 [details] [diff] [review]:
-----------------------------------------------------------------

What about simply checking the card state status in the settings app and hide/disabled the SIM Toolkit row if needed?
Attachment #699091 - Flags: approval-gaia-master?(21) → approval-gaia-master-

Updated

6 years ago
Whiteboard: interaction, UX-P2 → interaction, UX-P2 [triaged:1/15]
(In reply to Vivien Nicolas (:vingtetun) (:21) from comment #13)
> Comment on attachment 699091 [details] [diff] [review]
> Remove cached data on startup
> 
> Review of attachment 699091 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> What about simply checking the card state status in the settings app and
> hide/disabled the SIM Toolkit row if needed?

Because that will fix if NO SIM card is plugged, but if you plug a SIM card without STK app the code will detect a SIM card and will show the previous card cached menu.

Since the STK menu is only sent by STK powered SIM cards on startup we'll receive it each time the handset is turned on, so we only need to cache this data on startup. If no STK is supported cause no SIM card plugged or no STK card powered no proactive command will be received.
Flags: needinfo?(21)
(In reply to Fernando R. Sela [:frsela] from comment #14)
> (In reply to Vivien Nicolas (:vingtetun) (:21) from comment #13)
> > Comment on attachment 699091 [details] [diff] [review]
> > Remove cached data on startup
> > 
> > Review of attachment 699091 [details] [diff] [review]:
> > -----------------------------------------------------------------
> > 
> > What about simply checking the card state status in the settings app and
> > hide/disabled the SIM Toolkit row if needed?
> 
> Because that will fix if NO SIM card is plugged, but if you plug a SIM card
> without STK app the code will detect a SIM card and will show the previous
> card cached menu.
> 

That makes sense.
Flags: needinfo?(21)

Updated

6 years ago
status-b2g18: --- → fixed
Landed on mozilla-b2g18/gaia master prior to the 1/25 branching to mozilla-b2g18_v1_0_0/v1.0.0, updating status-b2g-v1.0.0 to fixed.
status-b2g18-v1.0.0: --- → fixed
verified fixed: 
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/778da49486f0
Gaia   6c3767c2dea43b5e9aff7d156d36d69649005621
BuildID 20130320070206
Version 18.0

Gecko  http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/e74dafa6b2d9
Gaia   1438da6ca0e020a8df686e2100a668370dfe6fb6
BuildID 20130312230202
Version 18.0
Status: RESOLVED → VERIFIED
status-b2g18: fixed → verified
status-b2g18-v1.0.1: --- → verified
You need to log in before you can comment on or make changes to this bug.