Mozilla crashes while loading this site

VERIFIED DUPLICATE of bug 58937

Status

()

VERIFIED DUPLICATE of bug 58937
18 years ago
16 years ago

People

(Reporter: damian, Assigned: serhunt)

Tracking

({crash, testcase})

Trunk
x86
Linux
crash, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.2-2 i686; en-US; rv:0.9) Gecko/20010511
BuildID:    2001051114

This above page asks the browser to fetch a js prog. It contains
a comment, and then a bunch of NUL's. When running galeon I get the
stdout message:-

JavaScript error: 
http://www.cnet.com/nonpage/surveys/SrcSiteSurvey/190.js line 5: illegal character

Before it crashes, however under Mozilla I get nothing.

I know this is invalid js, but it shouldn't crash the browser!


Reproducible: Always
Steps to Reproduce:
1.Well right now going to that URL works, however I don't know
how long it will be there. However I will attach the page and the
javascript that causes the problem (I wget'ed them).
2.
3.

Actual Results:  Crashes Mozilla

Expected Results:  Crashes Mozilla

Here is a stack trace from the core file, however without debug
symbols it probably is of no use.
(gdb) bt
#0  0x400b3539 in ?? ()
#1  0x0804a99b in ?? ()
#2  0x0804ae87 in nsCAutoString::~nsCAutoString ()
#3  0x0804bd13 in nsXPIDLString::~nsXPIDLString ()
#4  0x401d7177 in ?? ()
(Reporter)

Comment 1

18 years ago
Created attachment 34921 [details]
Main page referring to the javascript
(Reporter)

Comment 2

18 years ago
Created attachment 34922 [details]
The Javascript file

Comment 3

18 years ago
I am able to load this site with a Mozilla binary 2001050917 on WinNT.
The JavaScript console shows the same error you mention, 

JavaScript error: 
http://www.cnet.com/nonpage/surveys/SrcSiteSurvey/190.js 
line 5: illegal character


However, there is no crash at the site no matter what I do.
Thus the error is something separate from what's causing the crash.

I will try with a more recent binary, but in the meantime, 
reassigning this bug to Browser-General, as it is not JS Engine -
Assignee: rogerl → asa
Component: Javascript Engine → Browser-General
Keywords: crash
QA Contact: pschwartau → doronr
Summary: Invalid javascript char crashes Mozilla → Mozilla crashes while loading this site

Comment 4

18 years ago
Marking WORKSFORME. I can load this site fine with the most recent
nightly binaries: 20010517xx on WinNT, Linux.

damian@cisco.com: could you try a more recent build? If you can
load the site without crashing, please mark this bug Verified.
If not, you can reopen it - thanks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

18 years ago
I have further tested this and I realise that another key component is that
you need to be displaying on another window (i.e. not :0). I managed to
reproduce it just by starting mozilla thus:-

DISPLAY=localhost:0.0 mozilla

And then going to the web page.

Damian
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
(Reporter)

Comment 6

18 years ago
Sorry, that's still not right. DISPLAY=localhost:0.0 doesn't reproduce the
problem. However DISPLAY=127.0.0.1:0.0 does. There is probably something in X
that recognised localhost, but not 127.0.0.1

So try doing:-

DISPLAY=127.0.0.1:0.0 mozilla
http://news.cnet.com/news/0-1003-200-5940130.html?tag=lh

(above is one line of course)

Damian

Updated

18 years ago
Keywords: testcase

Comment 7

18 years ago
Here's the stack I got on a linux cvs build from this afternoon:
#0  __libc_free (mem=0x41461008) at malloc.c:3005
#1  0x40e00215 in _IcePaAuthDataEntries ()
   from /usr/local/mozilla/plugins/libflashplayer.so
#2  0x40da40a0 in compositeClassRec () from /usr/X11R6/lib/libXt.so.6


I set DISPLAY=127.0.0.1:0.0
Looks like another flash doesn't work remotely bug, like bug 83833.
Assignee: asa → av
Status: UNCONFIRMED → NEW
Component: Browser-General → Plug-ins
Ever confirmed: true
QA Contact: doronr → shrir

Comment 8

18 years ago
*** Bug 83833 has been marked as a duplicate of this bug. ***

Comment 9

17 years ago
*** Bug 111928 has been marked as a duplicate of this bug. ***

Comment 10

17 years ago
This is a long standing problem: Flash crashes on remotely exported display, bug
58937.

*** This bug has been marked as a duplicate of 58937 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago17 years ago
Resolution: --- → DUPLICATE

Comment 11

16 years ago
mass duplicate verifications . For filtering purposes, pls use keywd
"massdupverification"

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.