*2 and *8 are phone numbers(in Venezuela) the dialer treat them as MMI/USSD

RESOLVED FIXED

Status

P1
normal
RESOLVED FIXED
6 years ago
4 years ago

People

(Reporter: brg, Assigned: gtorodelvalle)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: Interaction design)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:16.0) Gecko/20100101 Firefox/16.0
Build ID: 20121024073032

Steps to reproduce:

Try to make a call to any of those two numbers: *2 or *8


Actual results:

The dialer treat them as MMI/USSD instead of trying to make a call.


Expected results:

Our implementation currently believes that anything that starts with * is a special number that should not be dialed. We are planning to handle this as part of the operator variant to be flexible to adapt to any launch country.

Updated

6 years ago
Component: Gaia → Gaia::Dialer
Correct me if I'm wrong but this is a requirement specific to Venezuela and it is not a standard. So it seems that we need to add a operator specific MMI exception list to the operator variant.
Blocks: 793178
(In reply to Beatriz Rodríguez [:brg] from comment #0)
> Our implementation currently believes that anything that starts with * is a
> special number that should not be dialed. We are planning to handle this as
> part of the operator variant to be flexible to adapt to any launch country.

IMHO the operator variant mechanism is not the solution for every quirk that appears in the countries we are going to launch the devices. If the quirk appears for *only* one country -or even some of them- let's try to move how to deal with it in the app itself first. IIRC the cost control app did that before for a similar issue.

Updated

6 years ago
Priority: -- → P1
Whiteboard: Interaction design
After commenting it with Beatriz and :ferjm (due to https://bugzilla.mozilla.org/show_bug.cgi?id=810178), we decided the following: A valid USSD/MMI code is any 'number' starting with #, or starting with * and with no * or # at the end. The USSD/MMI codes will be sent even if there is no SIM card available. In case of airplane mode, the USSD/MMI codes won't be sent either the phone number dialed.
(In reply to gtorodelvalle from comment #3)
> After commenting it with Beatriz and :ferjm (due to
> https://bugzilla.mozilla.org/show_bug.cgi?id=810178),

Sorry Germán, but how is this related to Bug 810178?

This bug is about handling carrier exceptions regarding MMI codes handling. It has no relation to the fact that we are not sending MMIs without a SIM card.
The new criteria according to :ferjm is that USSD/MMI codes are any 'phone number' ending in # ;-)
Assignee: nobody → gtorodelvalle
Created attachment 685107 [details] [diff] [review]
Associated PR.

NOTE: If blocking-basecamp+ is set, just land it for now.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: 
Testing completed: 
Risk to taking this patch (and alternatives if risky):
Attachment #685107 - Flags: review?(fernando.campo)
Attachment #685107 - Flags: approval-gaia-master?(francisco.jordano)
Attachment #685107 - Flags: review?(fernando.campo) → review+
Attachment #685107 - Flags: approval-gaia-master?(francisco.jordano) → approval-gaia-master+
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Reporter)

Updated

4 years ago
See Also: → bug 1030760
You need to log in before you can comment on or make changes to this bug.