Last Comment Bug 813730 - [traceback] UnicodeEncodeError: 'ascii' codec can't encode character u'\xe1' in position 2: ordinal not in range(128)
: [traceback] UnicodeEncodeError: 'ascii' codec can't encode character u'\xe1' ...
Status: RESOLVED FIXED
:
Product: Marketplace
Classification: Server Software
Component: Consumer Pages (show other bugs)
: 1.0
: All All
: P3 normal (vote)
: 2013-01-03
Assigned To: Allen Short [:ashort]
:
:
Mentors:
https://marketplace.firefox.com/app/d...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-20 13:46 PST by krupa raj[:krupa]
Modified: 2013-01-04 14:40 PST (History)
2 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description krupa raj[:krupa] 2012-11-20 13:46:11 PST
steps to reproduce:
1. Load https://marketplace.firefox.com/app/di%C3%A1rio-catarinense/reviews/add
2. Add a review.

observed behavior:
The POST after submitting the review form fails with a 500

traceback details:
Stacktrace (most recent call last):

  File "django/core/handlers/base.py", line 111, in get_response
    response = callback(request, *callback_args, **callback_kwargs)
  File "mkt/fragments/decorators.py", line 51, in wrapper
    utils.bust_fragments(response, url_prefix, *args, **kwargs)
  File "mkt/fragments/utils.py", line 32, in bust_fragments
    prefix = map(reformat_prefix, prefix)
  File "mkt/fragments/utils.py", line 28, in reformat_prefix
    return prefix.format(*args, **kwargs)

sentry: http://sentry.dmz.phx1.mozilla.com/marketplace/group/3216/
Comment 1 Allen Short [:ashort] 2012-12-12 12:22:09 PST
We seem to have more than one place that app slugs are assumed to be ASCII. Do we want to commit to supporting full unicode in slugs, or should we update the db to fix these outliers?
Comment 2 Rob Hudson [:robhudson] 2012-12-12 15:30:12 PST
When kumar and I talked about this previously, we wanted to go with ascii. Esp since app_slug is used to generate filenames.

Note You need to log in before you can comment on or make changes to this bug.