homescreen won't load: malformed manifest

RESOLVED DUPLICATE of bug 815895

Status

Firefox OS
Gaia::Homescreen
P1
critical
RESOLVED DUPLICATE of bug 815895
6 years ago
5 years ago

People

(Reporter: dietrich, Unassigned)

Tracking

({regression})

unspecified
x86
Mac OS X
regression

Firefox Tracking Flags

(blocking-basecamp:+)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
logcat: http://pastebin.mozilla.org/1949538

this is on unagi, when doing OTA update to 11/20 build.
(Reporter)

Updated

6 years ago
Severity: normal → critical
blocking-basecamp: --- → ?
Keywords: regression, regressionwindow-wanted
Priority: -- → P1

Updated

6 years ago
Component: Gaia → Gaia::Homescreen
I see this in a local build from the nightly branch but the homescreen loads just fine.  What are the specific symptoms you're seeing?

A logcat with a bit more context is http://pastebin.mozilla.org/1949609 .  The errors seem to originate with the update poller.

I wasn't seeing this on inbound.  Is there a patch waiting to be uplifted?
I pulled a random app directory and the manifest is valid JSON.
I think this is harmless warning from xhr trying to load the file as an XML document. I'll look into silencing that.
(Reporter)

Comment 4

6 years ago
The symptom is that the phone boots into the all black screen with "mozilla" in white text, and stays there.

If I hold the power button, I do get that menu. All other UI in the system is not accessible.

I'll try rebooting and getting a full log.
(Reporter)

Comment 5

6 years ago
Created attachment 683865 [details]
log
I think the 11/20 nightly was done from the aurora tree after the mc->aurora merge. cjones said tomorrows nightly will be from the beta branch. This might fix the problem if you could update :(
(Reporter)

Comment 7

6 years ago
Sounds like imma need to flash.

Maybe we should consider automatically downloading and applying updates if the platform detects that the UI never loads.
(In reply to Dietrich Ayala (:dietrich) from comment #7)
> Sounds like imma need to flash.

Yep. Note for the future: lets not build and distribute nightlies at merge dates.

Comment 9

6 years ago
(In reply to Gregor Wagner [:gwagner] from comment #8)
> Yep. Note for the future: lets not build and distribute nightlies at merge
> dates.

For one thing, we need some way to get people across versions and probably also channels, if possible. We did have something like that for some time on desktop with the channel switcher and it worked, even though it had some flaws, IIRC.

Is there any way to get a phone in that state into a working state without losing all data?
(In reply to Gregor Wagner [:gwagner] from comment #8)
> (In reply to Dietrich Ayala (:dietrich) from comment #7)
> > Sounds like imma need to flash.
> 
> Yep. Note for the future: lets not build and distribute nightlies at merge
> dates.

This sounds like a good plan to me.
Yeah, it's really important that once we merge from aurora to beta we don't do releases off of aurora any more. Otherwise when we switch from aurora to beta we could easily be downgrading users to and older version of gecko, something that we have never supported.

It's really important that we stay on a continuously-moving-forward gecko version. That means either staying on a single branch, like aurora, or on a single train, like ff18.
Status: NEW → UNCONFIRMED
Ever confirmed: false
Flags: needinfo?(dietrich)
(Reporter)

Comment 12

6 years ago
What is the needinfo request for?
Flags: needinfo?(dietrich)
blocking-basecamp: ? → +
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 815895

Updated

5 years ago
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.