Can't upload a new version

RESOLVED WORKSFORME

Status

addons.mozilla.org Graveyard
Developer Pages
--
major
RESOLVED WORKSFORME
6 years ago
2 years ago

People

(Reporter: Jason Barnabe (np), Unassigned)

Tracking

Details

(Reporter)

Description

6 years ago
On https://addons.mozilla.org/en-US/developers/addon/stylish/versions the "Upload a new version" button doesn't work. Loading the page, I get:

Timestamp: 12-11-20 09:31:19 PM
Error: SyntaxError: invalid quantifier
Source File: https://addons.cdn.mozilla.net/media/js/common-min.js?build=0eee516
Line: 15

Timestamp: 12-11-20 09:31:19 PM
Error: TypeError: z.button is undefined
Source File: https://addons.cdn.mozilla.net//en-US/firefox/addons/buttons.js?b=0eee516
Line: 15

Timestamp: 12-11-20 09:31:19 PM
Error: TypeError: $(".install").installButton is not a function
Source File: https://addons.cdn.mozilla.net/media/js/common-min.js?build=0eee516
Line: 18
I was not able to reproduce any JS errors on https://addons.mozilla.org/en-US/developers/addon/stylish/versions using the following browsers:

Firefox 16.0.2
Firefox Nightly 19.0a1 (2012-11-16)
Chrome 23.0.1271.64

What is your user-agent?
(Reporter)

Comment 2

6 years ago
Firefox 16.0.2.

Keep in mind you likely see a different page than I (the developer of the add-on) do.
As an admin, I see nearly the same page as you do - and no errors.

For one of my own add-ons, I was able to successfully upload a new version on https://addons.mozilla.org/en-US/developers/addon/amazona761/versions

Very strange, as I have the exact same user-agent, and I don't get any errors upon loading https://addons.cdn.mozilla.net/media/js/common-min.js?build=0eee516 Are you able to reproduce this in another profile/browser?
(Reporter)

Comment 4

6 years ago
Figured it out, it was something I had left enabled when testing bug 709954.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.