All users were logged out of Bugzilla on October 13th, 2018

Canvas gets confused about its path/transform state

RESOLVED FIXED in Firefox 19

Status

()

RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: jrmuizel, Assigned: jrmuizel)

Tracking

unspecified
mozilla20
x86
Mac OS X
Points:
---
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(firefox18-, firefox19- verified, firefox20 verified)

Details

Attachments

(3 attachments)

(Assignee)

Description

6 years ago
Created attachment 683872 [details]
Test case

This test case shows the problem.
(Assignee)

Comment 1

6 years ago
Created attachment 683874 [details] [diff] [review]
Clear out path.

I believe this is the correct fix and seems consistent with the code above, but I'm not sure.
Attachment #683874 - Flags: review?(ncameron)
Attachment #683874 - Flags: review?(bas)

Comment 2

6 years ago
Comment on attachment 683874 [details] [diff] [review]
Clear out path.

Review of attachment 683874 [details] [diff] [review]:
-----------------------------------------------------------------

I think this is right, seems consistent with the way ds path builder and mPath work elsewhere.
Attachment #683874 - Flags: review?(ncameron) → review+
Comment on attachment 683874 [details] [diff] [review]
Clear out path.

Review of attachment 683874 [details] [diff] [review]:
-----------------------------------------------------------------

Correct!
Attachment #683874 - Flags: review?(bas) → review+
Jeff is away this week so I will land this. Meanwhile we should ship this fix as early as possible. Lets track this bug.
tracking-firefox18: --- → ?
tracking-firefox19: --- → ?
tracking-firefox20: --- → ?
https://hg.mozilla.org/mozilla-central/rev/fb979e824816
Assignee: nobody → jmuizelaar
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla20
Can we get the test checked in?
Flags: in-testsuite?

Comment 8

6 years ago
(In reply to Benoit Girard (:BenWa) from comment #4)
> Jeff is away this week so I will land this. Meanwhile we should ship this
> fix as early as possible. Lets track this bug.

Is this a regression in FF17/18? Just want to better understand why this should track for release.
Given the lack of a case for uplift, removing tracking noms.  If you re-nom please explain what the user benefit or regression fix is here.
tracking-firefox18: ? → -
tracking-firefox19: ? → -
tracking-firefox20: ? → ---
I've been waiting on Jeff to get back from vacation to handle this. I'll let him renominate the issue.
(Assignee)

Comment 11

6 years ago
Comment on attachment 683874 [details] [diff] [review]
Clear out path.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Azure canvas regression (happened on Windows first, then OS X and most recently Linux)
User impact if declined: In correct canvas behaviour.
Testing completed (on m-c, etc.): All of the canvas tests
Risk to taking this patch (and alternatives if risky): Seems quite low risk
Attachment #683874 - Flags: approval-mozilla-aurora?
(Assignee)

Comment 12

6 years ago
(In reply to Jeff Muizelaar [:jrmuizel] from comment #11)
> [Approval Request Comment]
> User impact if declined:

We ran into this on the upverter.com site. So it was being hit be real world sites.

Updated

6 years ago
Attachment #683874 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/7408b9bd9f10
status-firefox19: --- → fixed
status-firefox20: --- → fixed

Updated

6 years ago
Summary: Canvas gets confused about it's path/transform state → Canvas gets confused about its path/transform state
Keywords: verifyme
Created attachment 715122 [details]
Firefox 19.0 test case behavior
Verified with Firefox 19 RC on a Mac OSX 10.7.5 machine.

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130215130331

The output is the one shown in the attachement from comment 14.

Updated

6 years ago
status-firefox19: fixed → verified
QA Contact: manuela.muntean
Verified the fix for Firefox 20.0 beta 1 with the attached testcase from comment 0 on Mac OS X 10.7.5.

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:20.0) Gecko/20100101 Firefox/20.0 (20130220104816)
status-firefox20: fixed → verified
mass remove verifyme requests greater than 4 months old
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.