[Keyboard] PIN keyboard act strange in SIM PIN edit

VERIFIED FIXED

Status

Firefox OS
Gaia::Keyboard
P2
normal
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: ypwalter, Assigned: rudyl)

Tracking

unspecified

Firefox Tracking Flags

(blocking-basecamp:+)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
*Environment:
Phone - Unagi
https://releases.mozilla.com/b2g/
2012-11-20 build

*How to reproduce:
  0. Flash your phone
  1. Go to settings
  2. Enable SIM PIN
  3. Click <input> area

*Expected Result:
  The pin keyboard come out.

*Actual Result:
  The pin keyboard come out, hide, come out, hide, come out.
(Reporter)

Updated

6 years ago
Flags: needinfo?(rlu)
Created attachment 684267 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/6568

Pointer to Github pull-request
Flags: needinfo?(rlu)
Comment on attachment 684267 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/6568

For Bug 791920, we add a workaround to blur to re-focus the input field to make sure the keyboard will pop up.

Now, this workaround would cause the keyboard to hide to show again, so we need to remove this workaround.
Attachment #684267 - Flags: review?(ehung)
The current behavior of our keyboard for SIM PIN is kind-of annoying that it will disappear and re-appear if you click it.
This will introduce bad user experience, so nominate as blocking.
blocking-basecamp: --- → ?

Comment 4

6 years ago
Comment on attachment 684267 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/6568

r=me, thanks.
Attachment #684267 - Flags: review?(ehung) → review+

Comment 5

6 years ago
Comment on attachment 684267 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/6568

NOTE: If blocking-basecamp+ is set, just land it for now.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: 
Testing completed: 
Risk to taking this patch (and alternatives if risky):
Attachment #684267 - Flags: approval-gaia-master?(21)
Attachment #684267 - Flags: approval-gaia-master?(21) → approval-gaia-master+
Resolve this issue with merging
https://github.com/mozilla-b2g/gaia/pull/6568
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Assignee: nobody → rlu
blocking-basecamp: ? → +
Priority: -- → P2
(Reporter)

Comment 7

6 years ago
Verified that this is fixed in 20121212 build from https://releases.mozilla.com/b2g/
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.