Closed Bug 814008 Opened 7 years ago Closed 7 years ago

opening any link creates multiple tabs

Categories

(Firefox :: Untriaged, defect)

17 Branch
x86
Windows XP
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 813763

People

(Reporter: bbresnik, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:16.0) Gecko/20100101 Firefox/16.0
Build ID: 20121024073032

Steps to reproduce:

Open a link, whether on a Firefox tab or in a Thunderbird email.
Firefox v. 17.0
Thunderbird v. 17.0
OS: Windows XP SP3, all patches applied as of 21 Nov 2012


Actual results:

Three tabs, rather than one, opened for that same link.


Expected results:

One tab should have opened.
Enabled plugins

Shockwave Flash

    File: C:\WINDOWS\system32\Macromed\Flash\NPSWF32_11_5_502_110.dll
    Version: 11.5.502.110
    Shockwave Flash 11.5 r502

MIME Type 	Description 	Suffixes
application/x-shockwave-flash 	Adobe Flash movie 	swf
application/futuresplash 	FutureSplash movie 	spl
VLC Web Plugin

    File: C:\Program Files\VideoLAN\VLC\npvlc.dll
    Version: 2.0.2.0
    VLC media player Web Plugin 2.0.2

MIME Type 	Description 	Suffixes
audio/mpeg 	MPEG audio 	mp2,mp3,mpga,mpega
audio/x-mpeg 	MPEG audio 	mp2,mp3,mpga,mpega
video/mpeg 	MPEG video 	mpg,mpeg,mpe
video/x-mpeg 	MPEG video 	mpg,mpeg,mpe
video/mpeg-system 	MPEG video 	mpg,mpeg,mpe,vob
video/x-mpeg-system 	MPEG video 	mpg,mpeg,mpe,vob
audio/mp4 	MPEG-4 audio 	aac,mp4,mpg4
audio/x-m4a 	MPEG-4 audio 	m4a
video/mp4 	MPEG-4 video 	mp4,mpg4
application/mpeg4-iod 	MPEG-4 video 	mp4,mpg4
application/mpeg4-muxcodetable 	MPEG-4 video 	mp4,mpg4
video/x-m4v 	MPEG-4 video 	m4v
video/x-msvideo 	AVI video 	avi
application/ogg 	Ogg stream 	ogg
video/ogg 	Ogg video 	ogv
application/x-ogg 	Ogg stream 	ogg
application/x-vlc-plugin 	VLC plug-in 	
video/x-ms-asf-plugin 	Windows Media Video 	asf,asx
video/x-ms-asf 	Windows Media Video 	asf,asx
application/x-mplayer2 	Windows Media 	
video/x-ms-wmv 	Windows Media 	wmv
video/x-ms-wvx 	Windows Media Video 	wvx
audio/x-ms-wma 	Windows Media Audio 	wma
application/x-google-vlc-plugin 	Google VLC plug-in 	
audio/wav 	WAV audio 	wav
audio/x-wav 	WAV audio 	wav
audio/3gpp 	3GPP audio 	3gp,3gpp
video/3gpp 	3GPP video 	3gp,3gpp
audio/3gpp2 	3GPP2 audio 	3g2,3gpp2
video/3gpp2 	3GPP2 video 	3g2,3gpp2
video/divx 	DivX video 	divx
video/flv 	FLV video 	flv
video/x-flv 	FLV video 	flv
application/x-matroska 	Matroska video 	mkv
video/x-matroska 	Matroska video 	mkv
audio/x-matroska 	Matroska audio 	mka
application/xspf+xml 	Playlist xspf 	xspf
audio/x-mpegurl 	MPEG audio 	m3u
video/webm 	WebM video 	webm
audio/webm 	WebM audio 	webm
application/vnd.rn-realmedia 	Real Media File 	rm
audio/x-realaudio 	Real Media Audio 	ra
audio/amr 	AMR audio 	amr
audio/x-flac 	FLAC audio 	flac
Shockwave for Director

    File: C:\WINDOWS\system32\Adobe\Director\np32dsw_1168638.dll
    Version: 11.6.8.638
    Adobe Shockwave for Director Netscape plug-in, version 11.6.8.638

MIME Type 	Description 	Suffixes
application/x-director 	Shockwave Movie 	dir,dxr,dcr
Nitro PDF Plug-In

    File: C:\Program Files\Nitro PDF\Reader 2\npnitromozilla.dll
    Version: 2.5.0.45
    Nitro PDF Plug-in for Firefox and Chrome

MIME Type 	Description 	Suffixes
application/pdf 	Acrobat Portable Document Format 	pdf
SumatraPDF Browser Plugin

    File: C:\Program Files\SumatraPDF\npPdfViewer.dll
    Version: 2.1.1.0
    SumatraPDF Browser Plugin

MIME Type 	Description 	Suffixes
application/pdf 	PDF document 	pdf
application/vnd.ms-xpsdocument 	XPS document 	xps
image/vnd.djvu 	DjVu document 	djvu
application/oxps 	OpenXPS document 	oxps
image/x-djvu 		
image/x.djvu 		
IE Tab Plug-in

    File: C:\Documents and Settings\Elise Bresnik\Application Data\Mozilla\Firefox\Profiles\igm53e7q.default\extensions\{1BC9BA34-1EED-42ca-A505-6D2F1A935BBB}\plugins\npietab2.dll
    Version: 2.2.0.1
    IE Tab 2 Plug-in for Mozilla/Firefox

MIME Type 	Description 	Suffixes
application/ietab2 	IE Tab 2 Plug-in 	
Windows Live® Photo Gallery

    File: C:\Program Files\Windows Live\Photo Gallery\NPWLPG.dll
    Version: 14.0.8051.1204
    NPWLPG

MIME Type 	Description 	Suffixes
application/x-wlpg3-detect 	Windows Live® Photo Gallery 	wlpg
application/x-wlpg-detect 	Windows Live® Photo Gallery 	wlpg
NPCIG.dll

    File: C:\Program Files\Canon\ZoomBrowser EX\Program\NPCIG.dll
    Version: 1.0.0.5
    CANON iMAGE GATEWAY Mycamera Plugin

MIME Type 	Description 	Suffixes
application/x-canon-cig 	Canon Online Photo Plugin Module 	cig
Windows Media Player Plug-in Dynamic Link Library

    File: C:\Program Files\Windows Media Player\npdsplay.dll
    Version: 3.0.2.629
    Npdsplay dll

MIME Type 	Description 	Suffixes
application/asx 	Media Files 	*
video/x-ms-asf-plugin 	Media Files 	*
application/x-mplayer2 	Media Files 	*
video/x-ms-asf 	Media Files 	asf,asx,*
video/x-ms-wm 	Media Files 	wm,*
audio/x-ms-wma 	Media Files 	wma,*
audio/x-ms-wax 	Media Files 	wax,*
video/x-ms-wmv 	Media Files 	wmv,*
video/x-ms-wvx 	Media Files 	wvx,*
Upgraded from v.16.02, which worked well, to v. 17.0, which exhibited issue above.
Reinstalled v. 16.02 (without removing v. 17.0) which works as expected  (no issue).
Can you reproduce the issue in the Firefox safemode ?
http://support.mozilla.org/en-US/kb/Safe+Mode
Matthias,
Running in Safe Mode works correctly, and might have pointed out the source of the issue:
After restarting Firefox 17.0 in Safe Mode, the installation did a check of all add-ons and listed Tab Mix Plus v. 0.4.0.3 as incompatible. Apparently, the original installation started Firefox 17.0 [checkbox to start was left checked] without compatibility tests.
Thanks for the suggestion; the bug, if it is counted as such, has to do with a failure to check add-on compatibility when run immediately from the installation.
Bart
TMP got later marked as incompatible by Mozilla (bug 813763).
So, it works without TMP ?
Yes, without TMP, it behaves as expected. 
Because Tab Mix Plus is important to me, I'll wait for it to be upgraded for compatibility with v. 17 before I upgrade Firefox. It would be useful if Firefox itself had exposed some of the options of TMP: X-mouse tab change, hiding tab buttons, opening of pages in tabs, mouse button options etc.
Thanks for letting me know of bug 813763... as an early adopter, I got bit by it.
Sorry for repeating a known issue.
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 813763
You need to log in before you can comment on or make changes to this bug.