"Talkback ID --> bug number" query web form

RESOLVED FIXED

Status

mozilla.org
Talkback Server & Webtool
--
enhancement
RESOLVED FIXED
17 years ago
7 years ago

People

(Reporter: Linards Ticmanis, Assigned: myk)

Tracking

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2 i686)
BuildID:    2001050521

It would be a good idea if there was a web form where you can enter
a talkback ID and find out if a bug has already been filed. So you can
avoid creating duplicate reports and maybe cast a vote instead. I'm not into the
bugzilla system enough to know if this is feasible.

Reproducible: Always
Steps to Reproduce:
1. Use bugzilla
2. Know a Talkback ID
3. Don't be able to run gdb
3. See no way of finding the right bug number.

Actual Results:  Filed a bug report that is probably a duplicate.

Expected Results:  Showed me a bug page to vote on.

I think that this could reduce the work load of the bug people and
make everybody create more useful reports.

Comment 1

17 years ago
Both the systems are not integrated. You can look at the report which we 
publish in the external mozilla ftp site to identify the stack signature and
query the bugzilla for the corresponding bug number. Stack signature are
entered into the summary if it is a topcrash.

Comment 2

17 years ago
Marking NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: PC → All
Summary: RFE: "Talkback ID --> bug number" query web form → [RFE] "Talkback ID --> bug number" query web form
namachi@netscape.com:
It would be nice if a few people outside NS could get TB data.
TB stack traces are very helpful to find dupes and/or the right component.
I need near everyday some TB stack traces because i need to find the right
components for bugs in Browser General (I'm currently the owner of b-g).
I usually has to ask some NS people but they are possible busy and or it's weekend.


I have a debug build only for stack traces but i can't reproduce every crash
and/or the crash is on a different platform (I'm using win32).

The access to the web-from could be limited to a few people who are helping in
bug triage..




Comment 4

16 years ago
We have a prototype working. I am finishing up the interface and data store with
mozilla group.

Comment 5

16 years ago
sounds good, so people won't have to bug me for talkbacks

Comment 6

16 years ago
I have a related question: Mozilla crashed on my mac, and as I had Macsbug, I
saved some information that might help debuggers. When I quit Macsbug, the
Talkback client started and I could enter a comment, however as the system was
unstable, I could not paste in from the StdLog file that Macsbug created. I just
had to send the talkback report with a few comments (didn't remember exactly
what I had seen in Macsbug). After reboot I could start Talkback and find the
correct talkback ID, and now I sit here with my StdLog. How can I search
bugzilla to find a duplicate bug, or how can I give the right persons this extra
debugging information ? Or should I just not bother before it shows up in a
topcrash bug, and I maybe find it by searching for the function name given by
StdLog ?

Updated

16 years ago
Summary: [RFE] "Talkback ID --> bug number" query web form → "Talkback ID --> bug number" query web form

Comment 7

15 years ago
namachi: Has this idea thrown away with the webinterface? Such a webinterface
for querying TB stacks would still be a good idea.

Comment 8

15 years ago
-> myk . 
Assignee: namachi → myk
QA Contact: chofmann → namachi

Comment 9

14 years ago
this has been fixed, see http://talkback-public.mozilla.org/
you can also find out if a bug has already been filed about this if you click a
line of the stacktrace (normally you take the first one).
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Updated

13 years ago
Component: Talkback → Talkback
Product: Core → mozilla.org
Version: Trunk → other
You need to log in before you can comment on or make changes to this bug.