Closed Bug 814076 Opened 7 years ago Closed 7 years ago

[Lockscreen] New lockscreen animation eats up CPU in the background

Categories

(Firefox OS Graveyard :: Gaia::System::Lockscreen, defect, P3)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-basecamp:+)

VERIFIED FIXED
blocking-basecamp +

People

(Reporter: diego, Assigned: yurenju)

References

Details

Attachments

(1 file)

No description provided.
I can see the CPU usage and power consumption spiking every 4 seconds or so. This goes away when I go back the old lockscreen animation by revering the following commits in gaia:

46dbd5e1233376438e2fdd027868b153a244f901
b2587db2352ca70922f0ccdee708bbace4271ce3
ec82ff70d9bbd3dc50424422e8be07d393e13415

Perhaps a lockscreen timer is still firing in the background?
Just to clarify, this is happening all the time, even when the screen has been unlocked!
blocking-basecamp: --- → ?
Component: Gaia::Homescreen → Gaia::System::Lockscreen
Blocks: 808607
Group: qualcomm-confidential
Definitely seems like we're not cancelling that "bouncy demo animation" timer.
This bug is making it hard to use the builtin fps counter effectively.
Assignee: nobody → jones.chris.g
@Yuren, would you beat cjones and come up with a fix?
If you have other blocking bugs, please fix those first.  I just need this fixed for analysis purposes.
I would like to take it! There are some problems about set/clear interval on screen on/off and lock/unlock.
Assignee: jones.chris.g → yurenju
While making measurements for bug 780692, I found that this is also significantly dinging startup time.
Blocks: slim-fast
Attached file Pull request
Tim, Could you please review this? Thanks!

https://github.com/mozilla-b2g/gaia/pull/6574
Attachment #684351 - Flags: review?(timdream+bugs)
Comment on attachment 684351 [details]
Pull request

r=me if you remove the screenEnabled part.

I don't like the `setPrompted` and `prompt` function name, but I am running out of ideas also... maybe `setUnlockAnimation` and `unlockAnimation` ?
Attachment #684351 - Flags: review?(timdream+bugs) → review+
But it's not a "unlock" animation... how about setTipAnimation or setRemindAnimation?
used ScreenManager instead of this.screenEnabled and used elastic instead of prompt!
Merged.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Sorry, it doesn't merge without bb+ yet.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Comment on attachment 684351 [details]
Pull request

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 806989
User impact if declined: All user because phone has lower battery life
Testing completed: 
Risk to taking this patch (and alternatives if risky):
Attachment #684351 - Flags: approval-gaia-master?(21)
blocking-basecamp: ? → +
Priority: -- → P3
Merged.
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → FIXED
The spikes are gone. Thanks!
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.