STK command for display text does not show text until the STK menu in settings is opened

RESOLVED FIXED in B2G C2 (20nov-10dec)

Status

Firefox OS
Gaia::Settings
P1
normal
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: cyang, Assigned: frsela)

Tracking

unspecified
B2G C2 (20nov-10dec)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-basecamp:+)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
It seems that it is by design that all the STK-related items are only displayed within the SIM Toolkit. However, this is a problem when running GCF tests. For example, when running the Display text TC 27.22.4.1.1.1:

- Start GCF test which prompts for device power up
- After power up, user is on the homescreen
- Proceed with GCF test (which sends the STK command for display text)
- Nothing is displayed on the UI
- Go into Settings->SIM Toolkit
- The display text is within the SIM Toolkit app

What is the Mozilla team input on this?
(Reporter)

Updated

6 years ago
Summary: STK displays in SIM Toolkit menu and not on homepage → STK displays in SIM Toolkit menu and not on homescreen
Blocks: 802677
Group: qualcomm-confidential
cc'ing Rafa for input here. 

UX decision was to move SIM Toolkit to settings because it provided little to no value to users, and hurt the signal to noise ratio of preinstalled apps.
blocking-basecamp: ? → -

Comment 2

6 years ago
That is indeed the case.  I agree with Josh that the key issue here is the signal to noise ratio. The value of STK is very limited and the impact on everyday use appears to be very reduced and occasional.

I'm not familiar with the depth and breath of interactions through the STK. Perhaps it's a matter of adequately launching Settings in the proper STK section/menu when this thing happens, in the same way SIM activation gains focus when needed. If it's something so simple as displaying a text string, we could minimise work and risk by using standard dialogs.
re-noming...this is a GCF failure that needs to be looked at more carefully
Status: UNCONFIRMED → NEW
blocking-basecamp: - → ?
Ever confirmed: true

Comment 4

6 years ago
We need some guidance from product here. dcoloma, we might need a waiver if this is a GCF requirement.
Flags: needinfo?(dcoloma)
The issue is not where the STK is displayed (changing bug title), I think this will be fixed as soon as the solution for bug 808919 lands. 

frsela can confirm.
Flags: needinfo?(dcoloma) → needinfo?(frsela)
Summary: STK displays in SIM Toolkit menu and not on homescreen → STK command for display text does not show text until the STK menu in settings is opened
(In reply to Daniel Coloma:dcoloma from comment #5)
> The issue is not where the STK is displayed (changing bug title), I think
> this will be fixed as soon as the solution for bug 808919 lands. 
> 
> frsela can confirm.

Yes, agree, The patch for bug 808919 will update the STK main title correctly. Anyway I think this bug refers to the STK commands send async., ie, without user interaction (like SIM Activation).

Since the settings policy changed (subsections will load under demand) and System Message is now managed by system instead of settings, we are changing the way of working.

I'm not really sure is the same bug as 808919 and 810831 anyway, this depends on that
Depends on: 808919
Flags: needinfo?(frsela)
blocking-basecamp: ? → +
Priority: -- → P1
Assignee: nobody → frsela
Created attachment 686516 [details]
Patch to support async. STK Commands

This patch adds support for STK commands (like unsolicited display texts and SIM Activation)
Attachment #686516 - Flags: review?(21)
Comment on attachment 686516 [details]
Patch to support async. STK Commands

Would it be possible to have a system message in Gecko to disambiguate between menu and other commands? If not I think we would have to do that the way you did but that seems like a hack (one more after the mozSettings one).
Attachment #686516 - Flags: review?(21) → review-
Target Milestone: --- → B2G C2 (20nov-10dec)
Can we land this, and file a followup for the improvement?
(In reply to Dietrich Ayala (:dietrich) from comment #9)
> Can we land this, and file a followup for the improvement?

I made many comments on github about this patch. It will not work with some build machines that are known to use GAIA_DOMAIN. So I think the answer is probably not.
(In reply to Vivien Nicolas (:vingtetun) from comment #8)
> Comment on attachment 686516 [details]
> Patch to support async. STK Commands
> 
> Would it be possible to have a system message in Gecko to disambiguate
> between menu and other commands? If not I think we would have to do that the
> way you did but that seems like a hack (one more after the mozSettings one).

That would be really nice ... but I tried it without any success ... platform changes are slower than gaia ones.

I think that this hack and the menu cache one are really horrible and should be managed at platform level with different system-messages and/or store menu_cmd on gecko memory and add a new method to recover it.

Since we don't have enough time to change all the things I think we should maintain this hack and create a follow up bug for improve it at gecko leve.

Regarding the review, I'll fix it just now.
(In reply to Fernando R. Sela [:frsela] from comment #11)
> (In reply to Vivien Nicolas (:vingtetun) from comment #8)
> > Comment on attachment 686516 [details]
> > Patch to support async. STK Commands
> > 
> > Would it be possible to have a system message in Gecko to disambiguate
> > between menu and other commands? If not I think we would have to do that the
> > way you did but that seems like a hack (one more after the mozSettings one).
> 
> That would be really nice ... but I tried it without any success ...
> platform changes are slower than gaia ones.
> 
> I think that this hack and the menu cache one are really horrible and should
> be managed at platform level with different system-messages and/or store
> menu_cmd on gecko memory and add a new method to recover it.
> 
> Since we don't have enough time to change all the things I think we should
> maintain this hack and create a follow up bug for improve it at gecko leve.
> 

Yeah. v2 I guess :/


I made some additional comments and after that you should be good to go.
Comment on attachment 686516 [details]
Patch to support async. STK Commands

Github PR updated
Attachment #686516 - Flags: review- → review?(21)
Comment on attachment 686516 [details]
Patch to support async. STK Commands

Please squash the commits and make a better message before landing. r+.
Attachment #686516 - Flags: review?(21) → review+
Squashed and merged: https://github.com/mozilla-b2g/gaia/commit/9c6ab0427a376befcceac6f89d3db0d3b7eb78cd

Thanks Vivien !
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.