HTTP response head drops empty headers completely

RESOLVED DUPLICATE of bug 669259

Status

()

RESOLVED DUPLICATE of bug 669259
6 years ago
6 years ago

People

(Reporter: bzbarsky, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

In particular, nsHttpHeaderArray::SetHeader treats an empty value as "remove the header".  This might be OK for request headers (though that's not obvious) but for response headers this means we return null instead of "" to JS for XHR objects if the server sends "Foo: " with no value, which seems wrong.
(Reporter)

Updated

6 years ago
Whiteboard: [CORS-testsuite]

Comment 1

6 years ago
Note that the issue is not SetHeader() per se: we've added a separate SetHeaderFromNet() that has different semantics (but they don't yet include keeping track of empty headers).
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 669259
(Reporter)

Comment 2

6 years ago
Ah, ok.

I'll move the "cause web-visible bustage" annotation to the other bug.  ;)
Whiteboard: [CORS-testsuite]
You need to log in before you can comment on or make changes to this bug.