Firefox17 rendering issues link buttons

RESOLVED WORKSFORME

Status

Tech Evangelism Graveyard
English Other
--
major
RESOLVED WORKSFORME
5 years ago
3 years ago

People

(Reporter: PeterNZ, Unassigned)

Tracking

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 684134 [details]
Firefox Issue Cottagecrafts_co_nz.doc

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:16.0) Gecko/20100101 Firefox/16.0
Build ID: 20121005155445

Steps to reproduce:

Opened my online shopping web page www.cottagecrafts.co.nz. Re-installed v16 and all worked as expected. 


Actual results:

The link buttons don't render. It only shows the first "Home" button. All other buttons are not rendered. People Can't go to my shop anymore. 


Expected results:

Web page should show a menu bar across the page with link buttons. See screenshots
(Reporter)

Updated

5 years ago
Severity: normal → major
Last good nightly: 2012-04-30
First bad nightly: 2012-05-01

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=cfaf90b22fc3&tochan
ge=6e34995a746e

confirmed by changing the UA:
Bug 588909 - Replace Gecko/<date> with Gecko/<version> in UA string
Blocks: 588909
Reporter: 
Your page is doing Useragent sniffing and it fails because our Useragent string format changed.

an example for the old User agent string
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0.8) Gecko/20100101 Firefox/10.0.8
and the new one:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0

btw: Thanks for the screenshot but please use an image format instead of a proprietary .doc in your next report.
Depends on: 814138

Updated

5 years ago
Assignee: nobody → english-other
Component: Untriaged → English Other
Product: Firefox → Tech Evangelism
Version: 17 Branch → unspecified
No longer depends on: 814138
(Reporter)

Comment 3

5 years ago
(In reply to Matthias Versen (Matti) from comment #2)
> Reporter: 
> Your page is doing Useragent sniffing and it fails because our Useragent
> string format changed.
> 
> an example for the old User agent string
> Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0.8) Gecko/20100101 Firefox/10.0.8
> and the new one:
> Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0
> 
> btw: Thanks for the screenshot but please use an image format instead of a
> proprietary .doc in your next report.

Thanks for the reply. I need some research to do in order to fix this. 

Re your comment about the .doc. I do agree with you. On the other side it would be good if I could attach multiple files to a bug. This way I could have attached the two before and after screenshots in jpg format. But it was easier to just dump them in a word doc. Yes I know I could have used a picture tool and create an image blah blah but honestly, I don't had the time and users (that'll be me!) usually go the easy (lazy?) way. 

Cheers

Peter
(Reporter)

Comment 4

5 years ago
Oh and another question: How can I fix this? 

Cheers

Peter
PeterNZ: looks like your site is now fixed, is that right?

Gerv
(Reporter)

Comment 6

5 years ago
Sorry I don't know what gives you this impression. I got some help elsewhere in form of a RegEx string. Unfortunately that fixes Firefox 17 issues but raises Firefox <17 issues. So no, it is not fixed. 

Regards

Peter
The change in Firefox gets reverted due to several pages that are doing stupid UserAgent sniffing.
Should be fixed with Firefox17.0.1
(help/about Firefox triggers n update)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.