Last Comment Bug 814138 - Javascript/DHMTL not appearing or working in Firefox 17
: Javascript/DHMTL not appearing or working in Firefox 17
Status: RESOLVED WORKSFORME
:
Product: Tech Evangelism Graveyard
Classification: Graveyard
Component: English US (show other bugs)
: unspecified
: x86 Windows XP
: -- normal
: ---
Assigned To: Dão Gottwald [:dao]
:
Mentors:
Depends on:
Blocks: 588909
  Show dependency treegraph
 
Reported: 2012-11-21 12:31 PST by Yuri
Modified: 2015-04-19 23:39 PDT (History)
4 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Yuri 2012-11-21 12:31:21 PST
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:16.0) Gecko/20100101 Firefox/16.0
Build ID: 20121024073032

Steps to reproduce:

no changes in site, reported by our site visitors, problem is confirmed on our machines updated to Firefox 17


Actual results:

our Javascript/ DHTML (javascript 1.2) dropdown menu is not appearing, therefore not functioning on homepage or any site page in Firefox 17. Not functioning in WIN XP Pro Sp3 nor Win 7 Pro SP1
http://www.bragg.com/
menu is placed directly under the Top main image, and spans the site window width.


Expected results:

Javascript/ DHTML menu should appear and function - site DHTML menu works in Firefox 16.0.2 and prior versions, also works fine in IE, all versions.
Comment 1 boris.e.silva.r 2012-11-21 18:15:19 PST
In my case many sites relying inf javascript or dhtml show without format in a plain blank webpage with only the text, pictures, etc out of place.
Reload the page dont work, ou had to do a fully reload clear all or press 
[shift] + [F5].

The extension are the same than Fx 16.0.2, in firefox safe mode happen the same
Comment 2 Matthias Versen [:Matti] 2012-11-22 05:57:26 PST
boris.e.silva.r@gmail.com: Bug reports are limited to one single issue. Your comment is offtopic and SPAM. Please contact the support (http://support.mozilla.org)


Back to this bug report:
Last good nightly: 2012-04-30
First bad nightly: 2012-05-01

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=cfaf90b22fc3&tochan
ge=6e34995a746e

Bug 588909 - Replace Gecko/<date> with Gecko/<version> in UA string

Reporter: 
Your page is doing Useragent sniffing and it fails because our Useragent string format changed.

an example for the old User agent string
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0.8) Gecko/20100101 Firefox/10.0.8
and the new one:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0
Comment 3 Gervase Markham [:gerv] 2012-11-27 03:50:57 PST
Yuri: the file "stmenu.js" on your site, which says at the top:
/*DHTMLMenu, (c) 2006, SourceTec Software Co.,LTD  -  www.sothink.com*/
is doing bad user agent sniffing, which has broken because of a change we made in Firefox 17.

The code has been compressed so it might be a bit tricky (although possible) to fix by editing it directly. Perhaps you could ask SourceTec Software for an updated version?

Gerv
Comment 4 eugene 2012-11-29 04:34:18 PST
I edited the version comparison line in the stcode.js file & it seemed to have sorted the issue.

Changed _r.bIsFX&&_r.oNav.version<=20021130 to _r.bIsFX&&_r.oNav.version>=16;
Comment 5 Matthias Versen [:Matti] 2012-12-01 13:45:15 PST
We reverted the change in the Useragent string in Firefox17.0.1 and this should remain.

Note You need to log in before you can comment on or make changes to this bug.