[traceback] TypeError: SimpleSearchForm() takes exactly 1 argument (2 given)

RESOLVED FIXED in 2012-12-13

Status

Marketplace
Consumer Pages
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: krupa, Assigned: ashort)

Tracking

2012-12-13
Points:
---

Details

(URL)

(Reporter)

Description

5 years ago
steps to reproduce:
1. Load https://marketplace.firefox.com/users/register?lang=fa&from=%2Fmn%2Fthunderbird%2Fusers%2Fregister

traceback details:
tacktrace (most recent call last):

  File "django/core/handlers/base.py", line 111, in get_response
    response = callback(request, *callback_args, **callback_kwargs)
  File "session_csrf/__init__.py", line 127, in wrapper
    response = f(request, *args, **kw)
  File "apps/users/views.py", line 673, in register
    {'form': form, 'register_action': reg_action})
  File "jingo/__init__.py", line 80, in render
    rendered = render_to_string(request, template, context)
  File "jingo/__init__.py", line 98, in render_to_string
    return template.render(**get_context())
  File "jinja2/environment.py", line 891, in render
    return self.environment.handle_exception(exc_info, True)
  File "/data/www/addons.mozilla.org/zamboni/apps/users/templates/users/register.html", line 2, in top-level template code
    {% from 'includes/forms.html' import required %}
  File "/data/www/addons.mozilla.org/zamboni/templates/impala/base_shared.html", line 4, in top-level template code
    {% extends 'impala/base.html' %}
  File "/data/www/addons.mozilla.org/zamboni/templates/impala/base.html", line 58, in top-level template code
    {% block site_header %}
  File "/data/www/addons.mozilla.org/zamboni/templates/impala/base.html", line 86, in block "site_header"
    {% block search_form %}
  File "/data/www/addons.mozilla.org/zamboni/templates/impala/base.html", line 89, in block "search_form"
    {% include 'impala/search.html' %}
  File "/data/www/addons.mozilla.org/zamboni/templates/impala/search.html", line 5, in top-level template code
    {% set search_form = SimpleSearchForm(request, search_cat) %}

sentry: http://sentry.dmz.phx1.mozilla.com/marketplace/group/3219/
(Reporter)

Updated

5 years ago
Summary: [traceback] https://marketplace.firefox.com/users/register?lang=fa&from=%2Fmn%2Fthunderbird%2Fusers%2Fregister → [traceback] TypeError: SimpleSearchForm() takes exactly 1 argument (2 given)
Assignee: nobody → ashort
Target Milestone: --- → 2012-12-13
(Assignee)

Comment 1

5 years ago
looks like cvan fixed it: https://github.com/mozilla/zamboni/commit/6d27e0df6385e629f4a7a2005bf245c35f90ec86
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.