Setting main screen "slides in" on startup

RESOLVED DUPLICATE of bug 815381

Status

Firefox OS
Gaia::Settings
RESOLVED DUPLICATE of bug 815381
5 years ago
5 years ago

People

(Reporter: cjones, Assigned: cjones)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Darnit, thought I'd filed this.  Have been sitting on a patch for over a week.

STR
 (1) Make sure settings app is closed
 (2) Launch it

The main screen will transition in.  This is slightly disorientation and will be a perf hit on startup while bug 780692 remains unfixed.
Created attachment 684257 [details] [diff] [review]
Initialize the root panel with "current" class
Attachment #684257 - Flags: review?(kaze)
Duplicate of this bug: 815381

Comment 3

5 years ago
Urk, I just wrote a different patch for this in bug 815381. I think we want the settings.js part that I put in my patch to avoid calling showPanel as well.
Please feel free to reverse the dup.  I'm not working on this atm.
Comment on attachment 684257 [details] [diff] [review]
Initialize the root panel with "current" class

Sorry for the late review. Please let me finish working on my C2 bugs before reviewing this: I’m not sure this patch wouldn’t raise issues when the Settings app is launched on a different panel (web activities…).
Duplicate of this bug: 815381
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 815381
Attachment #684257 - Flags: review?(kaze)
You need to log in before you can comment on or make changes to this bug.