Cannot set wrapColumn until the editor has been instantied

VERIFIED FIXED in M9

Status

P3
normal
VERIFIED FIXED
20 years ago
10 years ago

People

(Reporter: bugzilla, Assigned: akkzilla)

Tracking

Trunk
x86
Mac System 8.6

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

20 years ago
in my java script, if I try to set the wrapColumn right after setting the editor
type, it failed because the editor hasn't been instantied yet. The problem is
that I cannot set it later because I don't know when the editor will be ready
for it!

in msgComposeCommands.js:

window.editorShell.SetEditorType("text");
window.editorShell.wrapColumn = msgCompose.wrapLength;

Look's like that the auto wrapping will be broken for M7

Comment 1

20 years ago
Yes, we need a way for the editorShell to store values that must be set
in the editor once the editor has been instantiated. Should be pretty easy.

Is this a blocker, or a must-fix for M7?

Comment 2

20 years ago
Would be nice to fix for M7.  Right now, I can continue typing in the html mail
compose window, but the text doesn't wrap to the next line; instead I see the
scroll bar although the window doesn't scroll as I type.  Other symptoms
include: wrapping at strange places so that the text looks like:

this is a test
here is some more text - this part should have been on line 1

Tried this on 6/14 builds of Win32 and Linux.  Have not tried Mac yet.
(Assignee)

Updated

20 years ago
Status: NEW → ASSIGNED
Target Milestone: M8
(Reporter)

Updated

20 years ago
Blocks: 8481
(Reporter)

Updated

20 years ago
No longer blocks: 8481
(Assignee)

Comment 3

20 years ago
Sadly, I won't be able to commit to fix these in time for M8; we've had a huge
flood of regressions in the last few days and I'll need to spend my time on
tracking down where the bustage happened.
(Assignee)

Updated

20 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → FIXED
(Assignee)

Comment 4

20 years ago
A fix has been checked in; now the editor shell should store the wrap column
until the editor is created.

Updated

19 years ago
QA Contact: lchiang → pmock

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 5

19 years ago
Auto wrap is working in the composer editor but not in mail.  I logged a
separate bug 12320 on the mail issue.

For this bug, I verified that in the composer, the wrap column does work.  I
tested it in the following M9 builds:
  Win32 seamonkey 1999-08-16-09-m9 and 1999-08-20-16-m9 builds
  Linux seamonkey 1999-08-16-08-m9 build
  MacOS seamonkey 1999-08-20-16-m9 build.

Marking this bug verified for the composer editor.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.