initial file upload dialog box hangs on local file directory

REOPENED
Unassigned

Status

()

REOPENED
6 years ago
5 years ago

People

(Reporter: w.langdon, Unassigned)

Tracking

10 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 684404 [details]
bugzilla_example.png

User Agent: Mozilla/5.0 (X11; Linux i686 on x86_64; rv:10.0.10) Gecko/20121026 Firefox/10.0.10
Build ID: 20121026203047

Steps to reproduce:

Almost any file upload dialog box hangs (pointless blue animation of arrow chasing
its own tail) on poor networked file system. Presumably trying to gather information
on every file in the current directory. This takes ages.
Can we add a text box to allow user to enter path/filename directly rather than
picking from possibly huge file list.

Bill


Actual results:

Eventually list for files and directories appears.
(Attached screen shot failed to include animated arrow,
but does capture empty space present to user).


Expected results:

Suggested being able to enter filename directly.
Would also be nice if could cut-and-paste file names.

Problem seen in Firefox 10.0.10 but is general to many versions of firefox.
Problem is paricularly common/painful when trying to send gmail attachements
(Reporter)

Comment 1

6 years ago
Created attachment 684406 [details]
screeen shot successful dialog box
(Reporter)

Comment 2

6 years ago
ps: I tried raising this as a new comment but could not attach either screen shot
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 374011
(Reporter)

Comment 4

6 years ago
Thanks Matthias, I did not find Bug 374011 when I searched for existing bugs.
Bill
(Reporter)

Comment 5

6 years ago
Dear Matthias,
              I cant say I understood all of Bug 374011 but perhaps it can be summarised
as we have good reasons for not doing as you suggest. So I should not have been so
explicit. Using firefox with networked disks can be painful. I guessed that this is because
firefox is searching complete directories across the network. Perhaps the cause is something
else. Perhaps what ever it is doing could be made more efficient.

Should I open another (less prescriptive) bug report?

Thanks again
Bill
Firefox opens the filepicker from the OS Toolkit and on Linux it's a GTK2 filepicker.
It's a GTK2 issue in case there is something wrong with it.
We have AFAIK already a bug to switch to GTK3.
I don't think this is purely a duplicate; the filepicker being slow isn't duplicate of a bug to not invoke the filepicker at all.
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: DUPLICATE → ---
Component: Untriaged → Widget: Gtk
Product: Firefox → Core
(Reporter)

Comment 8

5 years ago
Has there been any progress on this?
On a our (busy) networked file system it can take 27 seconds just to open one directory.
Multiply this by the depth of the directory heirachy and it gets to be  unusable!
Bill
You need to log in before you can comment on or make changes to this bug.