Closed Bug 814406 Opened 7 years ago Closed 7 years ago

SVG's feGaussianBlur with an stdDeviation of 0 (zero) is blurry

Categories

(Core :: SVG, defect)

17 Branch
x86
Windows XP
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 852100

People

(Reporter: alexleduc, Unassigned)

Details

(Keywords: testcase)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:17.0) Gecko/17.0 Firefox/17.0
Build ID: 20121119183901

Steps to reproduce:

In an HTML 5 document, I use an SVG filter to blut a part of the content. 

<style>
#content_area {
	filter:url(#Gaussian_Blur);
}
</style>


<svg width="100%" height="100%">
	<filter id="Gaussian_Blur">
		<feGaussianBlur in="SourceGraphic" id="fe" stdDeviation="0" />
	</filter>
</svg>




Actual results:

The page loads with stdDeviation="0", but it is blurred even though the value zero should mean that it is not blurred at all. Right now, it doesn't look different than stdDeviation="0.1"




Expected results:

It start off stdDeviation="0", which means it should not be blurred.

This SVG filter has worked as expected in the previous versions of Firefox (before 17)
Could you attach a minimal testcase please.
Component: Untriaged → SVG
Product: Firefox → Core
Will do. Apparently it works fine in a simple page, so I will try to identify what is peculiar about my Web app that makes it render incorrectly.
Attached file reproduces the bug
Notice how hte border one of the 2 textareas on the right is blurred. 

Also, when slowly resizing either textareas (using the lower right handle), you should notice some or all parts of the form elements and text on the page becoming blurry as if the reflow makes the filter toggle on and off randomly.
Attachment #684502 - Attachment mime type: text/plain → text/html
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 852100
You need to log in before you can comment on or make changes to this bug.