If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Browser][TR 11-15-12] Not able to go back to Top Sites after loading a page

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Browser
RESOLVED WONTFIX
5 years ago
4 years ago

People

(Reporter: carlosmartinez, Unassigned)

Tracking

unspecified
x86_64
Windows 7
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Browser][TR 11-15-12], testrun 2, URL)

Tested with unagi with:

gaia 620399e
gecko 85d0121

STR:
1-Open browser app
2-Type www.google.com
3-Tap in the back button to go back to top sites

Expected result --> Top sites page is loaded
Actual result --> Back button is disabled
The start page is part of the browser app rather than a regular web page because about: pages generally don't work on B2G and because the start page needs to run in the same process as the browser app (i.e. not the content process) in order to access the places database.

It might be possible to add some kind of hack to always make the back button go back to the start page if the canGoBack is false, but I'm not sure that's the right thing to do.

Comment 2

5 years ago
UCID: browser-087
https://moztrap.mozilla.org/results/case/61213/
Whiteboard: [Browser][TR 11-15-12] → [Browser][TR 11-15-12], testrun 2

Comment 3

5 years ago
Repros on Unagi device Build ID: 20130115070201   using the december 5th kernel
This is really by design, but in the latest master there's now a feature where you can always return to the start page by closing the last tab.

Tony, could you update this test case accordingly?
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(tchung)
Resolution: --- → WONTFIX

Comment 5

4 years ago
assigned to austin to update the existing testcase with comment 4 for v1.1.
Flags: needinfo?(tchung) → in-moztrap?(amiller)
QA Contact: amiller

Comment 6

4 years ago
Test Case has been updated noting the new functionality expressed in comment 4
Flags: in-moztrap?(amiller) → in-moztrap+
You need to log in before you can comment on or make changes to this bug.