[Browser] Refactor Clear browsing history & Clear cookies confirmations to not use confirm() so can set class=danger

VERIFIED FIXED

Status

Firefox OS
Gaia::Browser
P2
normal
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: pabloUX, Assigned: daleharvey)

Tracking

({polish})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [sprintready]interaction, UX-P4 c=browser u=user, test-wanted)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Clear browsing history and clear cookies and stored data confirmations should have class=danger because they involve deleting info, so user must be warned
(Reporter)

Updated

5 years ago
Keywords: polish
Priority: -- → P2
Whiteboard: visual
Whiteboard: visual → interaction, UX-P4

Comment 1

5 years ago
Issue exists also in newest build, but used confirming dialog is actually javascript confirm() call - no way to change it's style, might be only redesigned to use some custom dialog popup instead of standard confirm()
Summary: [Browser] [BB] Clear browsing history & cookies confirmations should have class=danger → [Browser] Refactor Clear browsing history & Clear cookies confirmations to not use confirm() so can set class=danger
Whiteboard: interaction, UX-P4 → interaction, UX-P4 c=browser u=user
Whiteboard: interaction, UX-P4 c=browser u=user → [sprintready]interaction, UX-P4 c=browser u=user
Assignee: nobody → dale
Created attachment 779591 [details] [review]
nsure clear data dialogs have warning UI
Attachment #779591 - Flags: review?(bfrancis)
The test plan for this is to follow the user interaction and ensure that the relevant data is cleared, I dont think we want to specifically test that button has a danger class, but it wouldnt be hard to add
Whiteboard: [sprintready]interaction, UX-P4 c=browser u=user → [sprintready]interaction, UX-P4 c=browser u=user, test-wanted
Comment on attachment 779591 [details] [review]
nsure clear data dialogs have warning UI

I think there's an opportunity to split Browser Settings out into a separate module in a re-factor but we can do that later.

r+me with a few nits (see GitHub)
Attachment #779591 - Flags: review?(bfrancis) → review+
Merged in: https://github.com/mozilla-b2g/gaia/commit/8b4e59e8046a678bf2fd9bebf14e2d776848cf48
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
forgot to mention, nits were addressed
"mozilla-central" gecko revision="a4c1961bf723"
"gecko.git" "e1ec7bf56f833462f1f317defc6b05e697911b06"
"gaia.git" revision="c7272f0b45c9fdac9d551828987e343300e87bf6"
Build ID: 2013-07-25-03-02-11
MC/master build
Unagi

Buttons are now red for the "ok" button to delete instead of blue ; seems to be functioning correctly for 0, 1, or more bookmarks/cookies.
Status: RESOLVED → VERIFIED
Forgot to mention that I checked cancel as well.  Seems ok.  There are test cases testing the functionality of these buttons, so I think we're ok for test cases.
Attachment mime type: text/plain → text/x-github-pull-request

Comment 9

4 years ago
Uplifted due to Bug 941489.

v1.1.0hd: 5b4af0ffaae2956241842f9f146f15347dae3ad0
You need to log in before you can comment on or make changes to this bug.