update system requirements for Firefox/Thunderbird on Linux

RESOLVED FIXED

Status

www.mozilla.org
Pages & Content
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: bhearsum, Assigned: standard8)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
With 17.0 we require a newer GTK version than before. These bugs have details:
https://bugzilla.mozilla.org/show_bug.cgi?id=772563
https://bugzilla.mozilla.org/show_bug.cgi?id=793634

Updated

5 years ago
Assignee: nobody → akeybl

Updated

5 years ago
Assignee: akeybl → lsblakk
http://www.mozilla.org/en-US/firefox/17.0/system-requirements/ done for Firefox - passing on to Mark for TB.
Assignee: lsblakk → mbanner
(Assignee)

Comment 2

5 years ago
This was already done on Thunderbird prior to release:

http://www.mozilla.org/en-US/thunderbird/17.0/system-requirements/
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Should "GNOME 2.16 or higher" be removed from recommendations? Firefox/Thunderbird already requires "GTK+ 2.18 or higher". GTK 2.18 has been released with GNOME 2.28 - http://library.gnome.org/misc/release-notes/2.28/index.html.en#rndevelopers.gtk
Is it really possible to use GNOME 2.16 with GTK+ 2.18?
(In reply to Alexander L. Slovesnik from comment #3)
> Is it really possible to use GNOME 2.16 with GTK+ 2.18?

I think the GNOME version is irrelevant. Now, to answer your question, theoretically, yes, because gtk+ 2.x is backwards compatible. In practice, there probably aren't anyone with this combination, if gtk 2.18 came out at the time of GNOME 2.28 release.
You need to log in before you can comment on or make changes to this bug.