Menu bar should appear below tab bar in Windows XP

RESOLVED WONTFIX

Status

--
enhancement
RESOLVED WONTFIX
6 years ago
2 years ago

People

(Reporter: moray33, Unassigned)

Tracking

17 Branch
All
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [wontfix?])

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:16.0) Gecko/20100101 Firefox/16.0
Build ID: 20121108234947

Steps to reproduce:

Menu bar appears above the title bar/tabs in Windows XP. It's specially annoying with Thunderbird 17, because the 'tabs bar' has became the 'title bar' too, so the menu bar is above the title bar, on top of the window. It's ugly and annoying.



Expected results:

The menu bar is under the title bar/tabs.
You can also hide the menu bar by unticking it when you right click over the menu bar. If you need the menu bar it should be shown by pressing ALT or F10 (depending of the distribution). But you can also access a similar menu structure by clicking the AppButton on the right of the main toolbar (the one with the three bars).

If you don't want this possibilities and still want the menu bar below the tabs you can put this in userCrome.css:

#tabs-toolbar {
  -moz-box-ordinal-group: 10 !important;
}

#mail-toolbar-menubar2 {
  -moz-box-ordinal-group: 20 !important;
}
(Reporter)

Comment 2

6 years ago
Sorry, I use Linux at home, but at work I was
OS: Linux → Windows XP
No problem. Under Windows pressing ALT shows the menu bar.
(Reporter)

Comment 4

6 years ago
Ups, I send my previous message incomplete.

I don't know if I explained it well. What I was trying to say is that in Thunderbird 17 the title bar is now the 'tab bar' but the menu bar is above it. I have Thunderbird configured to show the menu bar, of course. But I think it's supposed to be under the title bar. In fact, in Windows 7 it is.
It's because on XP the menu bar above the other bars is standard, on Win7 not (see IE). If you want the menu bar always shown and under the tabs, then with the entries for the userChrome.css in comment 1 you can fix this for you.
(Reporter)

Comment 6

6 years ago
Ok. I'll search that file and do that. Thank you.

But, I was wondering if Thunderbir could include those lines in that file by default. I don't really think that anyone want the menu bar above the tabs.
Per comment 5, menu bar *above* tab bar is by design on WinXP, because that's the default position of menu bars for XP -> enhancement

I think this is reasonable design (and personally I'm happy with it). I don't have strong feelings about this, but it might be a wontfix candidate.
Severity: normal → enhancement
Hardware: x86_64 → All
Summary: Menu bar appears above the title bar/tabs in Windows XP → Menu bar should appear below tab bar in Windows XP
Whiteboard: [wontfix?]

Comment 8

2 years ago
Now that Win XP is unsupported, is there anything we can do here?
Flags: needinfo?(richard.marti)
No
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(richard.marti)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.