Intermittent test_playback_rate.html | Exited with code 11 during test run [@ soundtouch::FIRFilter::evaluateFilterMono] [@ soundtouch::FIRFilter::evaluateFilterStereo]

RESOLVED DUPLICATE of bug 814708

Status

()

Core
Audio/Video
--
critical
RESOLVED DUPLICATE of bug 814708
5 years ago
5 years ago

People

(Reporter: RyanVM, Unassigned)

Tracking

({crash, intermittent-failure})

Trunk
All
Linux
crash, intermittent-failure
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

https://tbpl.mozilla.org/php/getParsedLog.php?id=17282011&tree=Mozilla-Inbound

Rev3 Fedora 12x64 mozilla-inbound opt test mochitest-1 on 2012-11-22 09:09:42 PST for push 83e6a9456aaf
slave: talos-r3-fed64-045

TEST-UNEXPECTED-FAIL | /tests/content/media/test/test_playback_rate.html | Exited with code 11 during test run
PROCESS-CRASH | /tests/content/media/test/test_playback_rate.html | application crashed (minidump found)

Thread 33 (crashed)
 0  libsoundtouch.so!soundtouch::FIRFilter::evaluateFilterMono(float*, float const*, unsigned int) const [FIRFilter.cpp : 154 + 0x0]
    rbx = 0x0000000000000001   r12 = 0x0000000000000000
    r13 = 0x0000000000000000   r14 = 0x0000000000003f80
    r15 = 0x0000000000000020   rip = 0x00007f6629e9685c
    rsp = 0x00007f6617b8dca8   rbp = 0x00007f6617b8dcd0
    Found by: given as instruction pointer in context
 1  libsoundtouch.so!soundtouch::RateTransposer::downsample(float const*, unsigned int) [RateTransposer.cpp : 261 + 0x31]
    rbx = 0x00007f65f6ed9690   r12 = 0x00007f65f6ed96b0
    r13 = 0x0000000000001000   r14 = 0x00007f65f6ed96d8
    r15 = 0x0000000000001000   rip = 0x00007f6629e97310
    rsp = 0x00007f6617b8dce0   rbp = 0x00007f6617b8dd20
    Found by: call frame info
 2  libsoundtouch.so!soundtouch::SoundTouch::putSamples(float const*, unsigned int) [SoundTouch.cpp : 324 + 0x9]
    rbx = 0x00007f65e83d2780   r12 = 0x0000000000000000
    r13 = 0x0000000000000001   r14 = 0x0000000000001589
    r15 = 0x00007f65f5adf000   rip = 0x00007f6629e97720
    rsp = 0x00007f6617b8dd30   rbp = 0x00007f6617b8dd40
    Found by: call frame info
 3  libxul.so!mozilla::nsBufferedAudioStream::GetTimeStretched(void*, long) [AudioStream.cpp : 989 + 0x7]
    rbx = 0x00007f65e8032120   r12 = 0x0000000000000000
    r13 = 0x0000000000000001   r14 = 0x0000000000001589
    r15 = 0x00007f65f5adf000   rip = 0x00007f662806b2e1
    rsp = 0x00007f6617b8dd50   rbp = 0x00007f6617b8ddd0
    Found by: call frame info
 4  libxul.so!mozilla::nsBufferedAudioStream::DataCallback(void*, long) [AudioStream.cpp : 1014 + 0xd]
    rbx = 0x00007f65e8032120   r12 = 0x0000000000000000
    r13 = 0x00007f65f5adf000   r14 = 0x0000000000001589
    r15 = 0x0000000000001589   rip = 0x00007f662806b3be
    rsp = 0x00007f6617b8dde0   rbp = 0x00007f6617b8de20
    Found by: call frame info
 5  libxul.so!cubeb_run_thread [cubeb_alsa.c : 301 + 0xf]
    rbx = 0x00007f65e861da80   r12 = 0x00007f6604b04210
    r13 = 0x0000000000001589   r14 = 0x00007f65e861da88
    r15 = 0x00007f65f5adf000   rip = 0x00007f66287bb96b
    rsp = 0x00007f6617b8de30   rbp = 0x00007f6617b8dec0
    Found by: call frame info
Comment hidden (Treeherder Robot)
Summary: Intermittent test_playback_rate.html | Exited with code 11 during test run [@ soundtouch::FIRFilter::evaluateFilterMono] → Intermittent test_playback_rate.html | Exited with code 11 during test run [@ soundtouch::FIRFilter::evaluateFilterMono] [@ soundtouch::FIRFilter::evaluateFilterStereo]

Updated

5 years ago
Blocks: 810262
Severity: normal → critical
Crash Signature: [@ soundtouch::FIRFilter::evaluateFilterMono] [@ soundtouch::FIRFilter::evaluateFilterStereo]
Keywords: crash

Updated

5 years ago
Blocks: 814708

Comment 2

5 years ago
In windows XP too not start latest build SeaMonkey - if i use soundtouch.dll from software Reaper, not load XPCOM and if i use xpcom.dll from old build SeaMonkey too :-(

Comment 3

5 years ago
Build 20121124003007 in windows XP now started O.K.
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
I managed to reproduce this locally on Linux. It has the same root cause as Bug 814708: somehow the objects are either not constructed or are deleted when we attempt to use them. But then it gets interesting. In gdb, if I try to print the values from the AudioStream scope, everything seems fine, but if I go down the callstack, I get 0x5a5a5a5a pointers (freed memory) and bogus values. [1] is an examples gdb session that shows the problem.

[1]: http://pastebin.mozilla.org/1965848

Updated

5 years ago
No longer blocks: 814708, 438871
Depends on: 814708
Comment hidden (Treeherder Robot)
This is likely to have been fixed by the fix for bug 814708. Closing.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 814708
You need to log in before you can comment on or make changes to this bug.