Thunderbird's Menu button has vertical lines on it that seem out-of-place

RESOLVED FIXED in Thunderbird 20.0

Status

Thunderbird
Theme
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Hmmwhatsthisdo, Assigned: Paenglab)

Tracking

unspecified
Thunderbird 20.0
x86_64
Windows 7

Thunderbird Tracking Flags

(thunderbird17 wontfix, thunderbird18 fixed, thunderbird19 fixed, thunderbird20 fixed, thunderbird-esr17 fixed)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 684604 [details]
The menu button, with the vertical lines.

After upgrading to TB17, I noticed the new menu button has little vertical lines on it. After checking it on my laptop (both the desktop and laptop run Windows), it became clear it wasn't a graphics card bug. I'm not sure if they're supposed to be there, but the really seem out-of-place. After looking at them for a while, I suppose they *kinda* look like the dividers in the menu bar, but they still seem fairly out-of-place. Perhaps someone should remove them in the next update?
(Assignee)

Comment 1

5 years ago
Also the Firefox button will change to this glyph, see: http://people.mozilla.com/~shorlander/files/australis-designSpecs/australis-designSpecs-windows7-mainWindow.html. Other OS and applications are also using this symbol for menus and this will help to faster recognize there is a menu behind this button.

I close this bug with WONTFIX because of the reasoning I wrote.

Feel free to reopen this bug if you think you have a better solution which also Firefox will use.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 2

5 years ago
Yes, I fully expected to see a menu Button like the one in the mock-up. however, this one includes vertical lines on it. Perhaps it's the viewing angle, but they are much harder to see in the picture attached than they are in my window. These vertical lines (the thin, almost invisible ones - not the 3 horizontal ones) seem entirely out of place. 

Since I believe Richard misunderstood the report, re-marking as UNRESOLVED and un-marking WONTFIX.
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---
(Assignee)

Comment 3

5 years ago
Sorry, I misunderstood you. Yes this is correct, I see them too.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 4

5 years ago
Created attachment 684615 [details] [diff] [review]
patch

Mike, I take you for review as you have always a Win7 machine ready.

I checked all other graphics and it is only this one affected. I don't know how this could happen.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #684615 - Flags: review?(mconley)
Comment on attachment 684615 [details] [diff] [review]
patch

Confirmed that this fixes the issue.
Attachment #684615 - Flags: review?(mconley) → review+
(Assignee)

Updated

5 years ago
Keywords: checkin-needed
(Assignee)

Comment 6

5 years ago
Comment on attachment 684615 [details] [diff] [review]
patch

[Approval Request Comment]
I'm asking for approval down to TB 17 in the hope this can land also on this channel to fix the visual glitch also there and the users haven't to wait until TB 24.
This patch should be riskless as it only exchanges the image.
Attachment #684615 - Flags: approval-comm-release?
Attachment #684615 - Flags: approval-comm-esr17?
Attachment #684615 - Flags: approval-comm-beta?
Attachment #684615 - Flags: approval-comm-aurora?
Attachment #684615 - Flags: approval-comm-release?
Attachment #684615 - Flags: approval-comm-esr17?
Attachment #684615 - Flags: approval-comm-esr17+
Attachment #684615 - Flags: approval-comm-beta?
Attachment #684615 - Flags: approval-comm-beta+
Attachment #684615 - Flags: approval-comm-aurora?
Attachment #684615 - Flags: approval-comm-aurora+
https://hg.mozilla.org/comm-central/rev/e2ec99c4e48a
https://hg.mozilla.org/releases/comm-aurora/rev/9c171b6e699a
https://hg.mozilla.org/releases/comm-beta/rev/7425fe0b83b7
https://hg.mozilla.org/releases/comm-esr17/rev/f9e20e7722f3
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago5 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 20.0
status-thunderbird17: --- → wontfix
status-thunderbird18: --- → fixed
status-thunderbird19: --- → fixed
status-thunderbird20: --- → fixed
status-thunderbird-esr17: --- → fixed
You need to log in before you can comment on or make changes to this bug.