Firefox always re-opens tabs from previous session, despite being told not to do so.

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
6 years ago
5 years ago

People

(Reporter: smcc, Unassigned)

Tracking

17 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0
Build ID: 20121119183901

Steps to reproduce:

Updated to version 17.0


Actual results:

Each time I open Firefox it re-opens all of the tabs from the previous session despite having been told not to.


Expected results:

It should open at my home page.

Comment 1

6 years ago
Change this behaviour in Options:
General > When Firefox starts > Show my home page
(Reporter)

Comment 2

6 years ago
No point in doing that as this is already the setting. I am not a novice.
(Reporter)

Comment 3

6 years ago
This has only happened since the update to version 17.0 and removing and re-installing Firefox makes no difference.

Comment 4

6 years ago
Thanks for taking the time to report this!
Does the problem still happen if you start Firefox in Safe Mode? (Safe Mode disables extensions and themes, hardware acceleration and some JavaScript stuff in order to exclude some possible reasons for problems. It does not disable plugins which are add-ons.) See http://support.mozilla.com/en-US/kb/Safe+Mode 

And does this also happen with a new and empty profile? See http://support.mozilla.com/en-US/kb/Basic%20Troubleshooting#w_8-make-a-new-profile and http://support.mozilla.org/kb/Managing%20profiles . 

If you still see this problem in the new profile, please enter the address "about:support" in the address bar and attach (using the "Add an attachment" link above) the output for your original profile (not the new profile), as the "Modified Preferences" section could be interesting. 
Thanks for your help!
Flags: needinfo?(stewartmccormick)
Summary: Since updating to Firefox 17.0 each time I open Firefox it re-opens the tabs from the previous session, despite being told not to do so. → Firefox always re-opens tabs from previous session, despite being told not to do so.

Comment 5

6 years ago
Do you use any tab-related extensions, such as Tab Mix Plus? If so, try disabling them and see if that fixes it.
(Reporter)

Comment 6

6 years ago
(In reply to Andre Klapper from comment #4)
> Thanks for taking the time to report this!
> Does the problem still happen if you start Firefox in Safe Mode? (Safe Mode
> disables extensions and themes, hardware acceleration and some JavaScript
> stuff in order to exclude some possible reasons for problems. It does not
> disable plugins which are add-ons.) See
> http://support.mozilla.com/en-US/kb/Safe+Mode 
> 
> And does this also happen with a new and empty profile? See
> http://support.mozilla.com/en-US/kb/Basic%20Troubleshooting#w_8-make-a-new-
> profile and http://support.mozilla.org/kb/Managing%20profiles . 
> 
> If you still see this problem in the new profile, please enter the address
> "about:support" in the address bar and attach (using the "Add an attachment"
> link above) the output for your original profile (not the new profile), as
> the "Modified Preferences" section could be interesting. 
> Thanks for your help!

It does still happen in Safe Mode but not in an empty profile. I have created a new profile and transferred files as instructed in http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox. 

The new profile seems to have solved the problem but I have no idea why it happened. I have also re-installed my add ons with no recurrence of the problem.
Would you still like to see my original profile?  

(In reply to mjh563 from comment #5)
> Do you use any tab-related extensions, such as Tab Mix Plus? If so, try
> disabling them and see if that fixes it.

No. I don't use any such extensions.
Flags: needinfo?(stewartmccormick)
I couldn't reproduce this issue with the latest Nightly.

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:20.0) Gecko/20.0 Firefox/20.0
Build ID: 20121126030823

Comment 8

5 years ago
smcc, can you still reproduce this problem?
Flags: needinfo?(stewartmccormick)
Whiteboard: [closeme 2014-02-15]
(Reporter)

Comment 9

5 years ago
The problem has not recurred following all updates since version 17.
Flags: needinfo?(stewartmccormick)

Comment 10

5 years ago
thanks
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
Whiteboard: [closeme 2014-02-15]
You need to log in before you can comment on or make changes to this bug.