In addressbook-panel.js, we define a global boolean variable gMsgCompose. In MsgComposeCommands.js, we define a global object variable gMsgCompose. While both variable scopes don't mix, it's plain confusing – given that about 86/94 of the current usages mean the latter … Thus, we should rename the former.
Yeah, that was my fault, I just couldn't be bothered to type gThisSidebarPanelIsInAMsgComposeWindow.
Created attachment 693794 [details] [diff] [review] Rename patch. (v1)
Assignee: nobody → ewong
Status: NEW → ASSIGNED
Attachment #693794 - Flags: review?(iann_bugzilla)
Comment on attachment 693794 [details] [diff] [review] Rename patch. (v1) Looks good r=me
Attachment #693794 - Flags: review?(iann_bugzilla) → review+
Pushed to comm-central: http://hg.mozilla.org/comm-central/rev/d0cff14ac3c3
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.17
You need to log in before you can comment on or make changes to this bug.