Add sidebar to messenger

VERIFIED FIXED in M9

Status

P1
normal
VERIFIED FIXED
20 years ago
14 years ago

People

(Reporter: sol, Assigned: scottputterman)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

20 years ago
[Build ID 1999061409]

The Sidebar panels currently included with Seamonkey Navigator are not displayed
in Messenger. The left pane of Messenger (in 3-pane view) should include Sidebar
panels for "Flashes" and "Mozilla Tinderbox" consistent with the panels included
in Navigator.

Steps to reproduce:
1. Start apprunner
2. Launch Messenger (Tasks | Messenger)
[Sidebar panels are missing from the left pane of Messenger]

Updated

20 years ago
OS: Windows 95 → All
QA Contact: lchiang → nbaca
Hardware: PC → All

Updated

20 years ago
Assignee: phil → alecf

Comment 1

20 years ago
The spec (http://gooey/client/5.0/specs/mail/messenger/messenger.shtml) says
we're supposed to have the Flash panel, and a News panel (of course there's a
name clash in mail/news). You're not saying we should have the same panels as
Navigator, right? That's not the plan as I understand it.

Reassigning to alecf

Updated

20 years ago
Target Milestone: M8

Comment 2

20 years ago
I talked to slamm about this late last week, and he says the sidebar isn't QUITE
modular enough to just dump into messenger. It will be first on my M8 list.

Updated

20 years ago
Status: NEW → ASSIGNED
Priority: P3 → P1
Summary: Sidebar panels not displayed in Messenger → Add sidebar to messenger

Comment 3

20 years ago
Sidebar must be in M8. Raising priority

Comment 4

20 years ago
going on vacation, mass-moving these M8 bugs to M9
Target Milestone: M8 → M9
(Assignee)

Updated

20 years ago
Assignee: alecf → putterman
Status: ASSIGNED → NEW
(Assignee)

Comment 5

20 years ago
reassigning to me since I added this.  I didn't put the Tinderbox panel in since
that didn't make sense to me in mailnews.  However I did put the folder pane and
the flash panel.
(Assignee)

Updated

20 years ago
Status: NEW → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → FIXED

Updated

20 years ago
Status: RESOLVED → VERIFIED

Comment 6

20 years ago
Build 1999071911M9: Win32/NT4, Linux Redhat 5.2, Mac 8.5.1
Verified Fixed. The Sidebar is now enabled on all platforms.

Note: Waiting on Project Management to answer questions as to what panels to
list and the exact wording (i.e. Email Folders, Mail Folders or Messenger
Folders). Once that is decided then I will log a separate bug for Sidebar panel
issues.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.