Closed Bug 814800 Opened 7 years ago Closed 7 years ago

AppMenu: Addon menu items etc. are missing, cannot use AppMenu as a full replacement for menu bar

Categories

(Thunderbird :: Untriaged, defect)

17 Branch
x86
Windows XP
defect
Not set

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: bege10, Unassigned)

References

Details

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:17.0) Gecko/17.0 Firefox/17.0
Build ID: 20121119183901

Steps to reproduce:

The new menu does not show all items of the old menu bar. 



Actual results:

Especially the entries of add-ons in the tools menu are missing - but others also.
This menu seems to be a completely new set up menu with new menu and menu item id. Therefore the CuteButtions icons don't work either.


Expected results:

The Firefox menu simply brought the menu bar into a new form - all settings and icons are still working. 
Please, do the same with the new Thunderbird menu. The way it is it is of no help. I either need both, the new menu and the old menu bar, or I simply stick with the menu bar.
Blocks: TB-AppMenu
Summary: New menu is not a useful replacement for menu bar → AppMenu: Addon menu items etc. are missing, cannot use AppMenu as a full replacement for menu bar
Firefox haven't simply brought the menu bar into a new form. They also used new IDs. If a Add-on wants his entry in the AppMenu it has to do it by itself like on the Firefox side. We need unique IDs to not break other things.

We can't and we don't change every Add-on to be compatible with the new AppMenu.

Please ask the Add-on authors to fix this in their extension.
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.