Unable to select first letter of url with mouse / home key

VERIFIED DUPLICATE of bug 80048

Status

SeaMonkey
Location Bar
VERIFIED DUPLICATE of bug 80048
17 years ago
10 years ago

People

(Reporter: Roger Light, Assigned: Alec Flett)

Tracking

({regression})

Trunk
x86
Windows 98
regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98)
BuildID:    2001051704

If the first letter that is typed into the url bar (that is the letter on the 
far left, regardless of whether it is typed at a time point before the other 
letters) is one of a certain letter then pressing the "Home" key or trying to 
select the url by dragging the mouse pointer over the url from right to left 
will leave the caret/end of selection just before the first letter. Double 
clicking the word selects it correctly.

This behaviour manifests itself for the following characters:

bc  fg  jk  no  rs  vw  
23  67

Whitespace included to emphasise the pattern. The same effect occurs for non-
alphanumeric characters, eg. " + but I am not going to try and produce a 
comprehensive list :)

Reproducible: Always
Steps to Reproduce:
1. Type a word into an empty urlbar, starting with a letter from the list in 
the description.
2. Press "Home"


Actual Results:  Caret will not be at far left. If the word typed is "bod", the 
caret will be inbetween the "b" and the "o".

Expected Results:  The caret should move to the far left.
All of the text should be mouse selectable.

Also produced similar results in 2001051504, but I didn't carry out extensive 
tests on it (ie. it didn't work but I don't know for which letters)

Comment 1

17 years ago
Can't duplicate this with 2001-05-16-04 under Win2k-SP1

Erase everything currently on URL bar.
Type 'bod'.
Hit the HOME key.
Everything works fine. Selecting it by draging right2left or left2right works
fine too.

Comment 2

17 years ago
Confirmed Also seeing this in any text box. Changing component and marking new

Platform: PC
OS: Windows 98
Mozilla Build: 2001051704

Must have regressed since yesterday.

This is Mouse & Keyboard.
Assignee: alecf → pchen
Status: UNCONFIRMED → NEW
Component: URL Bar → XP Apps
Ever confirmed: true
Keywords: regression, ui
QA Contact: claudius → sairuh
->urlbar or selection?
Assignee: pchen → alecf
Component: XP Apps → URL Bar
QA Contact: sairuh → claudius

Comment 4

17 years ago

*** This bug has been marked as a duplicate of 80048 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 5

17 years ago
VERIFIED Dupe
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.