If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

crash when displaying certain webpage in mail window

VERIFIED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
--
critical
VERIFIED WORKSFORME
17 years ago
13 years ago

People

(Reporter: Rob Jaworski, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
mozilla0.9.2
PowerPC
Mac System 9.x

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

17 years ago
I received a piece of spam mail from iplanet.  It was an html page with a bunch
of javascript.  When I tried opening and viewing it within mail (using buildID
20010516), it crashed the whole app; crashed it every time.  I saved the html
doc locally as a seperate file.  When viewing it in the browser window, you can
see it.  But if you email it to yourself (attach the file to your mail) and try
to see it in mail, you get the crash.

I've only tried this on Mac; not sure if it's xp.

I'll attach the file to this bug report.
(Reporter)

Comment 1

17 years ago
Created attachment 35027 [details]
this is the file-of-doom
(Reporter)

Comment 2

17 years ago
I've been submitting lots of talkback incidents on this.  The most recent is
TB30580068H.

Comment 3

17 years ago
I'm crashing a lot to on my Mac while testing attachments.  The web pages I have 
crashed on are yahoo.com, abcnews.com.  I wasn't crashing earlier this week with 
these pages.  I'm going to go back to the 5-14 build to see what happens.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

17 years ago
More investigation shows that if I add plain text to the message body with an 
attached web page I don't crash. If I just add the attached page and open it I 
crash.  Jean-Francois said that if you open the messge in POP it doesn't crash 
or open a plain text message before the crashing message it won't crash. 
Rob, if you could see if on of the 2 things I mentioned above enable you to open 
the crashing message, then we can mark this a dup of the bug ducarroz has 
opened.  
(Reporter)

Comment 5

17 years ago
> if I add plain text to the message body
> with an attached web page I don't crash
This is true for me with some attachments (eg, forward a bugzilla bug report)
but not for others (eg, my attachment to this bug).

>If I just add the attached page and open it I crash
This is true for me.

> if you open the messge in POP
I'm using imap, not gonna switch right now (sorry!).

> (if you) open a plain text message before
> the crashing message it won't crash
This is true for me with some attachments (eg, forward a bugzilla bug report)
but not for others (eg, my attachment to this bug).

Here's something else I discovered....
- open mail then select a plain text message to view
- maximize the header pane (in other words, close out the msg body pane)
- click on a 'crasher' msg
- go to View Message Source
- view the source of the 'crasher' message then close that window
- re-open the msg body pane
- view the 'crasher' mail

You should now be able to see that fatal message.

This worked for me even with my deadly attachment, and now this is the only way
I am able to view that message in mail.
can you use 4.x and save off the message in rfc-822 format and attach it here?
(Reporter)

Comment 7

17 years ago
Created attachment 35407 [details]
The whole mail message
thanks for attaching the rfc-822 message.

I'm not able to reproduce this on my fresh wint build, but I was able to 
reproduce this on my mac, but my mac build is a little old.

I'll attach the stack traces and then rebuild and see if it crashes with a more 
recent build.
Created attachment 35419 [details]
stack trace of crash
crash is in imgLoader::LoadImage(), cc'ing the libpr0n guys.

rebuilding on my mac now.
Target Milestone: --- → mozilla0.9.2
no more crasher after updating and rebuilding!

I do assert in the cookie service, but I'll log a new bug on that.

rob, can you try today's mac build and if it works for you mark this wfm?
logged bug #82001 to cover the assert (in the cookie service)
(Reporter)

Comment 13

17 years ago
Using buildID 2001052112, seems to workforme.  I even tried viewing the
attachment, closing the whole app down, restarting again, then viewing it again,
and it worked.

One other thing to mention is that mail never seems to finish loading that
message; the throbber keeps going.  Hit Stop and it stops.  Read a different
message, go back to this message, then it seems to load and finish loading.

Anyway, good job.
please log a new bug on the throbber problem.

marking wfm.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
verifying wfm based on rob's comments.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.