Closed Bug 8149 Opened 21 years ago Closed 20 years ago

Task Switcher Bar not displayed in Messenger

Categories

(SeaMonkey :: MailNews: Message Display, defect, P3)

defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: sol, Assigned: hangas)

Details

[Build ID 1999061409]

The Task Switcher Bar ("Web", "Mail", etc.) currently included with Seamonkey
Navigator (at the bottom of the screen) is not displayed in Messenger. Messenger
(in 3-pane view) should include Task Switcher Bar consistent with the Task
Switcher Bar included in Navigator.

Steps to reproduce:
1. Start apprunner
2. Launch Messenger (Tasks | Messenger)
[Task Switcher Bar missing from Messenger]
OS: Windows 95 → All
QA Contact: lchiang → nbaca
Hardware: PC → All
Assignee: phil → alecf
Target Milestone: M9
On the milestones doc, it says alecf is doing this for M9. Setting owner and
milestone to reflect that.
Status: NEW → ASSIGNED
Paul, is this something that can be easily done for M9 with the new overlay
code?
Assignee: alecf → hangas
Status: ASSIGNED → NEW
davidm is working on adding this to the tasksOverlay.xul file.  Once he does, we

can glue this into all the mailnews windows that use taskbar.  Assigning this bug

to me, putterman can take it from me if he wants.  :-)
Status: NEW → ASSIGNED
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
Fixed.  Also added it to address book and compose window.
Status: RESOLVED → REOPENED
Build 1999080208M9: Win32/NT4 and Linux/Redhat 5.2, Mac

The Task Switcher Bar is now in the Mail Main window, the Address Book and the
Compose window. I checked the Compose spec and it doesn't appear that the Task
Switcher Bar is suppose to be included in this window. I confirmed this with
jglick.
Resolution: FIXED → ---
Clearing Fixed resolution due to reopen.
Status: REOPENED → ASSIGNED
We should discuss this.  While I agree that the full taskbar is somewhat large to
inflict on the compose window, I would miss the icons for Navigator, Mail,
Address Book, etc.  Let's talk to UE and see what they think...
Target Milestone: M9 → M11
I don't think we need to make this decision by M9.  Moving to M11.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → FIXED
Marking as fixed.  The task switcher bar has been added to the mail/news windows.

The bug had been reopened to remove the taskbar from the messenger compose
window.  German has overruled the mailnews issues meeting decision and Sol has
approved, we will now have a full size taskbar in the messenger compose window.
Status: RESOLVED → VERIFIED
Buildd 1999092309M11: Win32/NT4, Linux/Redhat 5.0, Mac 8.5.1
Verified Fixed.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.