Closed Bug 814929 Opened 7 years ago Closed 6 years ago

SeaMonkey Chatzilla Localisation broken for 2.15 Betas

Categories

(Mozilla Localizations :: ca / Catalan, defect)

x86_64
Windows 7
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: Callek, Assigned: egamonal)

References

Details

So Properties in ./chrome/chatzilla.properties don't match... 

This compare-locales failure actually causes the localisation to not build. I marked it as Rejected on the dashboard (pointing at this bug) and manually backed out the localisation of the Catalan locale for chatzilla until this is fixed.

Once it is, I'll need to add that back in.

Comparing ca to en-US
Properties in ./chrome/chatzilla.properties don't match:
  In ../../../extensions/irc/locales/en-US: (add these to your localization)
    cmd.rename.params
    cmd.rename.help
    cmd.rename.label
    msg.tab.name.prompt
    msg.cd.updated
    msg.cd.updated.format
    msg.cd.updated.never
    pref.autoperform.channel.label
    pref.autoperform.channel.help
    pref.autoperform.client.label
    pref.autoperform.client.help
    pref.autoperform.network.label
    pref.autoperform.network.help
    pref.autoperform.user.label
    pref.autoperform.user.help
  In /builds/slave/comm-aurora-lnx-l10n-ntly/build/releases/l10n/mozilla-aurora/ca/extensions/irc: (remove these from your localization)
    msg.cd.title

Entities in ./chrome/channels.dtd don't match:
  In ../../../extensions/irc/locales/en-US: (add these keys to your localization)
    network.label
    network.accesskey
    channel.label
    channel.accesskey
    network.hint.label
    col.network
  In /builds/slave/comm-aurora-lnx-l10n-ntly/build/releases/l10n/mozilla-aurora/ca/extensions/irc: (remove these keys from your localization)
    qsearch.accesskey
    qsearch.label

make[2]: *** [libs] Error 1
make[2]: Leaving directory `/builds/slave/comm-aurora-lnx-l10n-ntly/build/comm-aurora/mozilla/extensions/irc/locales'
make[1]: *** [libs-ca] Error 2


As a result there is no ca translation for Chatzilla in 2.15 Beta 1
Assignee: toniher → egamonal
my compare-locales never showed that error, so I can't assure it's fixed now.
it should, though. http://hg.mozilla.org/releases/l10n/mozilla-aurora/ca/rev/ee5d0c942cc7
(In reply to Eduard Gamonal from comment #2)
> my compare-locales never showed that error, so I can't assure it's fixed now.
> it should, though.
> http://hg.mozilla.org/releases/l10n/mozilla-aurora/ca/rev/ee5d0c942cc7

We already took for our 2.15 run I'll verify if this is fine for 2.16 though.
(In reply to Justin Wood (:Callek) from comment #3)
> (In reply to Eduard Gamonal from comment #2)
> > my compare-locales never showed that error, so I can't assure it's fixed now.
> > it should, though.
> > http://hg.mozilla.org/releases/l10n/mozilla-aurora/ca/rev/ee5d0c942cc7
> 
> We already took for our 2.15 run I'll verify if this is fine for 2.16 though.

Hi Justin,
I guess this is working correctly now. Can I mark this as resolved+verified fixed?
any updates here?
Again, my compare-locales didn't report errors and I checked manually 2 missing strings reported by the dashboard
sorry, c#4 fell through the cracks. Things look good now to me, thank you!
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.