RESOLVED FIXED

Status

RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: federico.01, Assigned: rhelmer)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0
Build ID: 20121119183901

Steps to reproduce:

https://crash-stats.mozilla.com/report/index/1c26698f-5a42-4eff-911c-748782121124


Actual results:

Something bad happened. It's not you, it's me.
Component: Untriaged → General
Product: Firefox → Socorro
Version: 17 Branch → unspecified
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 1

6 years ago
I'm hitting what I imagine is the same bug.

https://crash-stats.mozilla.com/report/list?range_value=7&range_unit=days&date=2012-12-03&signature=F2102588022______________________________________________________________________________________________________&version=Firefox%3A17.0.1

Links to

https://crash-stats.mozilla.com/report/index/b74aa9df-9d79-46fe-9826-9fc5c2121201

and other crash reports that fail to load, with the message

"Something bad happened. It's not you, it's me.  Please file an issue in Bugzilla describing what happened, and please include the URL for this page."
Some crash reports load (e.g. https://crash-stats.mozilla.com/report/index/d880c546-9576-4652-87dc-011892121205), so it is not system wide.

Next step: checking logs.
(Assignee)

Comment 4

6 years ago
(In reply to Robert Helmer [:rhelmer] from comment #3)
> The frontend is throwing an exception here:
> 
> https://github.com/rhelmer/socorro/blob/master/webapp-php/application/views/
> report/index.php#L360

2012-12-06 04:06:14 +00:00 --- error: [5xx Error] File: application/views/report/index.php; Line: 360; Message: Undefined offset: 0
(Assignee)

Comment 6

6 years ago
From irc:

9:35 < ted> there was a breakpad change that let us get info out for some 
             threads even if we couldn't read some of the other threads
09:36 < ted> this was 
             http://code.google.com/p/google-breakpad/source/detail?r=1077
(Assignee)

Comment 7

6 years ago
(In reply to Robert Helmer [:rhelmer] from comment #6)
> From irc:
> 
> 9:35 < ted> there was a breakpad change that let us get info out for some 
>              threads even if we couldn't read some of the other threads
> 09:36 < ted> this was 
>              http://code.google.com/p/google-breakpad/source/detail?r=1077

This is not a regression, since before we would have shown a completely blank report.. we are working on a fix for it regardless, should be simple. The view code assumes that it can there is a thread from 0 to the maximum thread number and tries to iterate over each, we can just guard against that case now.
(Assignee)

Updated

6 years ago
Assignee: nobody → rhelmer
Status: NEW → ASSIGNED
(Assignee)

Comment 8

6 years ago
Confirmed that this already works as expected in the django version of crash-stats (VPN only):
http://crash-stats-new-dev.allizom.org/report/index/8aa61ff4-05c7-460f-a7c3-5aaf32121206

Comment 10

6 years ago
Commits pushed to master at https://github.com/mozilla/socorro

https://github.com/mozilla/socorro/commit/006ac2df94e13a1482f419903fa1e66ad6596535
bug 814968 - processed crashes may be missing threads, iterate over what is there instead

https://github.com/mozilla/socorro/commit/a64be72b78cde9f474b7a7a7077485982a533c02
Merge pull request #988 from rhelmer/bug814968-partial-thread-dump

bug 814968 - processed crashes may be missing threads, iterate over what...
(Assignee)

Updated

6 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.