Closed Bug 815000 Opened 9 years ago Closed 9 years ago

Invalid calls to sizeSocialPanelToContent in error conditions cause console errors.

Categories

(Firefox Graveyard :: SocialAPI, defect)

17 Branch
defect
Not set
normal

Tracking

(firefox17 wontfix, firefox18+ fixed, firefox19+ fixed, firefox20 fixed, firefox-esr17 wontfix)

RESOLVED FIXED
Firefox 20
Tracking Status
firefox17 --- wontfix
firefox18 + fixed
firefox19 + fixed
firefox20 --- fixed
firefox-esr17 --- wontfix

People

(Reporter: markh, Assigned: markh)

References

Details

(Whiteboard: [qa-])

Attachments

(1 file)

There are a few calls to sizeSocialPanelToContent which pass invalid params:

http://mxr.mozilla.org/mozilla-central/source/browser/base/content/browser-social.js#363
http://mxr.mozilla.org/mozilla-central/source/browser/base/content/browser-social.js#890

Both of the above are in the error handling code and only pass a single param when 2 are expected.
Attached patch Fix argsSplinter Review
Assignee: nobody → mhammond
Status: NEW → ASSIGNED
Attachment #685915 - Flags: review?(felipc)
Comment on attachment 685915 [details] [diff] [review]
Fix args

Review of attachment 685915 [details] [diff] [review]:
-----------------------------------------------------------------

thanks for catching this!
Attachment #685915 - Flags: review?(felipc) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/b2352627fb63

Gavin,
  This bug isn't too serious, but will mean that in error conditions, the toolbar and flyout panels will not be sized correctly and will cause an error to be written to the console.  Should we uplift this anywhere?
Flags: needinfo?(gavin.sharp)
(ESR10 is not affected, I'm pretty sure!)

Yeah, given the simplicity of the fix, let's get this on beta/aurora.
Flags: needinfo?(gavin.sharp)
https://hg.mozilla.org/mozilla-central/rev/b2352627fb63
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 20
Comment on attachment 685915 [details] [diff] [review]
Fix args

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 766616
User impact if declined: Panels with social error messages may be mis-sized.
Testing completed (on m-c, etc.): Landed on m-c
Risk to taking this patch (and alternatives if risky): Low risk - only impacts social in error conditions
String or UUID changes made by this patch: None
Attachment #685915 - Flags: approval-mozilla-beta?
Attachment #685915 - Flags: approval-mozilla-aurora?
Attachment #685915 - Flags: approval-mozilla-beta?
Attachment #685915 - Flags: approval-mozilla-beta+
Attachment #685915 - Flags: approval-mozilla-aurora?
Attachment #685915 - Flags: approval-mozilla-aurora+
Please remove [qa-] whiteboard tag and add verifyme keyword if there's some QA testing needed here. Otherwise we will skip verification.
Whiteboard: [qa-]
Wontfixing for esr17 since this doesn't meet landing criteria there. Would reconsider if there was a lot of requests from the mailing list or in this bug saying this was a significant issue in ESR deployments.
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.